Closed Bug 271208 Opened 16 years ago Closed 2 years ago

Firefox Resource Kit

Categories

(Firefox :: General, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nospam, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

IMO Firefox should have a "Firefox Resource Kit".

This could be similar to the Windows Resource Kits, containing documentation on
Firefox installation/rollout/support and configuration utilities.
For example a command-line prefs editor (ideal for logon scripts), a centralised
policy manager (for example to stop users changing their home page), and a
centralised extension manager.
Also it could include a TweakFirefox extension, similar to TweakUI for windows.

Perhaps this could be released at the same time as the MSI? I think it would be
very useful for corporates.

This is not a dupe of Bug 266700 as that deals only with a Firefox
Administration Kit.

Reproducible: Always
Steps to Reproduce:
N/A



Take a look at http://www.microsoft.com/windows2000/techinfo/reskit/default.asp
and http://www.microsoft.com/MSPress/books/5238.asp.

The printed version of a Firefox Resource Kit could be sold by the Mozilla
store, and if you look at the prices MS charge it could be a good earner.
Depends on: MSI
Blocks: 241532
Assignee: bross2 → nobody

We now have various Firefox Enterprise facilities, include Group Policy and various documentation.

If there's anything missing after that, I would suggest asking on the Firefox mailing list about if it could be added/included.

Enterprise information is here:

https://www.mozilla.org/firefox/enterprise/

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.