Closed Bug 271236 Opened 15 years ago Closed 15 years ago

find as you type steals focus from some form fields

Categories

(Toolkit :: Form Manager, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 258285

People

(Reporter: daniel+bugzilla, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

if you have "begin finding when you begin typing", then for some input boxen
in web forms, as you begin typing your input, the find dialog will appear, and
steal focus. You will then have to click inside the input box after every
character, in order to be able to type the next. I believe I've only seen this in
password entries. Sometimes, restarting the browser helps. Right now I can
reproduce that on https://mail.yahoo.com (note https protocol). I have password
remembered for that page FWIW.

Reproducible: Sometimes
Steps to Reproduce:
1. choose accessibility/ "begin finding when you begin typing"
2, go to https://mail.yahoo.com ( note https)
3. try typing in the password field

Actual Results:  
see above

Expected Results:  
kept the focus in the input box - I don't need to search the page for my password.
it seems "begin finding as you start typing" needs to be on when the browser starts.

*** This bug has been marked as a duplicate of 258285 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.