Closed Bug 271267 Opened 17 years ago Closed 16 years ago

[Submission] Detect whether uploaded file is theme or extension

Categories

(addons.mozilla.org Graveyard :: Developer Pages, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bugzilla-alanjstrBugs, Unassigned)

References

Details

Attachments

(1 obsolete file)

When someone is uploading a file with an install.rdf, we can tell whether it is
a theme or not, at least for FX and TB.

Themes have an instance of em:internalName.

If someone tries to upload a new item incorrectly, this will catch it and
prevent us from having to go back and fix it manually.
The question is not whether we can, the question is, do we really *need* to? and
is it practical to?

For once, let's wait and see what real authors who use the system actually
want/need, before filling buglists with minor bugs like this.
Summary: Detect whether uploaded file is them or extension → Detect whether uploaded file is theme or extension
Bulk Moving Developer Control Panel bugs to new component.
(Filter: massdevcpspam)
Component: Update → Developers
Product: mozilla.org → Update
Version: other → unspecified
Assignee: nobody → Bugzilla-alanjstrBugs
Status: NEW → ASSIGNED
This way we don't have to guess Theme or Extension based on the URL.
Attachment #169129 - Flags: first-review?(psychoticwolf)
Comment on attachment 169129 [details] [diff] [review]
Allow user to not have to specify theme or extension

Question: if bug 271272 is moving this to RDF parsing and not regexs. why is
this patch using a regexp? This probably should be done right, if it's going to
be done at all and be built on top of the pending patches in Bug 271272.

Aside from that, I'm still unconvinced that this gains us anything besides
unexpected trouble if em:internalName is ever fubared by an author.
Particularly considering this patch removes the previous code and doesn't allow
for author error.
if em:internalName is fubarred, then the theme jar is invalid.

I patched against current source, since you hadn't reviewed or checked in the
RDF parsing patch.
Attachment #169129 - Flags: first-review?(psychoticwolf)
Target Milestone: --- → 2.0
Summary: Detect whether uploaded file is theme or extension → [Submission] Detect whether uploaded file is theme or extension
Comment on attachment 169129 [details] [diff] [review]
Allow user to not have to specify theme or extension

we use the XML parser now
Attachment #169129 - Attachment is obsolete: true
Mass change - bugs to be read / (re)confirmed.
Assignee: Bugzilla-alanjstrBugs → nobody
Status: ASSIGNED → NEW
Priority: -- → P5
AMO bugspam. Correcting QA contacts on OLD bugs (mozilla.update@update.bugs)

-> Correct QA contact (developers@add-ons.bugs)

Filtermeplzkthx
QA Contact: mozilla.update → developers
Fixed in Remora (though I wonder about things like the Joga extension, which also had a theme component to them).
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.