Right-floating div's width does not match right margin of another div

RESOLVED WORKSFORME

Status

()

Core
Layout: Floats
--
minor
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Marten Klencke, Unassigned)

Tracking

({qawanted, testcase})

Trunk
x86
Linux
qawanted, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When there is a block div with a right margin of a specific number of pixels and
a float to cover this right margin exactly, sometimes the float doesn't cover
enough.

Reproducible: Always
Steps to Reproduce:
1. Maximize the browser window on the example URL
2. Slowly decrease the horizontal size.
Actual Results:  
At some point a vertical line will show up in the blue top bar. This should not
occur since margin-right of the main bar and the width of the top right float
are equal. This remains also when the page is reloaded with a visible vertical line.

Expected Results:  
The vertical white line should not be there. The float should always exactly
cover the margin.

To workaround, simple make the margin slightly less than the width of the float.
Component: General → Layout
Product: Firefox → Core
Version: unspecified → Trunk
This needs a minimal testcase...  Looks like a rounding issue somehow, though.
Assignee: firefox → nobody
Keywords: qawanted
QA Contact: firefox.general → core.layout
Created attachment 168046 [details]
testcase

This is as small as I could get. I fixed the body width (to 594px) so no window
resizing is required to see the white line.

Updated

13 years ago
Keywords: testcase
Uri, thanks!  Definitely a rounding issue.
Status: UNCONFIRMED → NEW
Component: Layout → Layout: Floats
Depends on: 177805
Ever confirmed: true
QA Contact: core.layout → core.layout.floats
This WFM since 2005-03-29 trunk builds. Not sure what fixed it.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.