nsMemory::HeapMinimize() crashes

RESOLVED FIXED

Status

()

Core
XPCOM
--
critical
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: dougt, Assigned: Benjamin Smedberg)

Tracking

({crash, regression})

Trunk
x86
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
regression caused by bug 267767
(Reporter)

Comment 1

14 years ago
Created attachment 166814 [details] [diff] [review]
Puts sFlushLock in the NS_MEMORY_FLUSHER_THREAD ifdef
(Reporter)

Updated

14 years ago
Attachment #166814 - Flags: review?(bsmedberg)
(Assignee)

Comment 2

14 years ago
Comment on attachment 166814 [details] [diff] [review]
Puts sFlushLock in the NS_MEMORY_FLUSHER_THREAD ifdef

Actually, darin was wrong when he asked me to #ifdef this in the first place.
This lock is needed even if we don't use the memory-flusher thread, since
memory-flushing can be forced from client code or out-of-memory situations. The
real solution is not to #ifdef any of the sFlushLock/sIsFlushing calls.
Attachment #166814 - Flags: review?(bsmedberg) → review-

Updated

14 years ago
Keywords: crash, regression
(Assignee)

Comment 3

14 years ago
Created attachment 166846 [details] [diff] [review]
Move the #ifdef so the lock is always used
Assignee: dougt → bsmedberg
Attachment #166814 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Comment 4

14 years ago
Comment on attachment 166846 [details] [diff] [review]
Move the #ifdef so the lock is always used

Darin or dougt, fell free to review.
Attachment #166846 - Flags: review?(darin)

Comment 5

14 years ago
Comment on attachment 166846 [details] [diff] [review]
Move the #ifdef so the lock is always used

r=darin

of course ;-)
Attachment #166846 - Flags: review?(darin) → review+

Comment 6

14 years ago
*** Bug 271382 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

14 years ago
fixed on trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Severity: normal → critical

Comment 8

14 years ago
*** Bug 271605 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Depends on: 267767
You need to log in before you can comment on or make changes to this bug.