Control Panel entry for Firefox (might be obsel. due to 1.5 mass install extensions/themes)

RESOLVED WONTFIX

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED WONTFIX
14 years ago
13 years ago

People

(Reporter: Dan Fischbach, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)

I had this idea, but I found the comment listed above.  As noted in the comment:

Go here: https://bugzilla.mozilla.org/show_bug.cgi?id=264889#c17

[snip]
As for a Control Panel item you're meant to create a .cpl file, but it's also
possible to create a CLSID for a Firefox Control Panel (which launches
C:\\PROGRA~1\\MOZILL~1\\FIREFOX.EXE -chrome
\"chrome://browser/content/pref/pref.xul\") and then add it to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace.
[/snip]

I did not want to talk about that specific part of the NameSpace feature,
because it would detract focus, so I made it a new enhancement.

My thoughts on it are:
----------------------
Entry in Control Panel: Firefox Options
----------------------
What it does:
----------------------
Basically a modded version of your usual Firefox options panel, with options for
adding themes or extensions.  You would be able to add many themes and
extensions rather quickly as the browser isn't in memory persay.  If it is,
could we make this some sort of seperate application or something small that
wouldn't need the entire browser to be in memoery?  (I know how you guys are on
overall filesizes).  This would further expedite the Firefox "experience" and
say to Microsoft: "See?  We can put stuff in your Control Panel too!"
---Either:---
*The normal Internet Options icon would be hidden (replaced with "Firefox
Options".  A registry key could hide the original)
-OR-
It could totally replace the Internet Options dialog (including adding the
Firefox icon.  Basically the above idea, but renaming it to "Internet Options")
-OR-
The "Firefox Options" could just be added and not hide the normal Internet
Options (I can't think of a time when, if you don't use IE, that you actually
need this tool).

This enhancemnt could be added in a future "Admin Install" of Firefox as I hear
custom installers are in the works to roll out on networks.  Home users could
have the option too.  ;-)

Thanks for your time.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
(Reporter)

Updated

13 years ago
Flags: blocking-aviary2.0?

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
extension, not FF
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
Peter6, you closed this too quickly: he's asking for a *control panel* extension
to be provided by Firefox, not for a Firefox extension. I'm not sure this makes
sense, but I'd like to see what beltzner/mconnor think.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

13 years ago
Status: UNCONFIRMED → NEW
Component: Installer → OS Integration
Ever confirmed: true
QA Contact: installer → os.integration
(Reporter)

Updated

13 years ago
Summary: Control Panel extension for Firefox → Control Panel entry for Firefox (might be obsel. due to 1.5 mass install extensions/themes)
We already provide a context menu entry for "Firefox Options" on the Firefox
shortcut that appears in the Start Menu when you set Firefox to be the default
browser. I'm not sure if there's a lot of extra value to an entire Control Panel
entry for us as well.

Do we know if it's possible to override the "Internet Options" control panel entry?
(Reporter)

Comment 4

13 years ago
Yes, I recently noticed this option.  We wouldn't really override it per
say...you can hide .cpl files that appear in the Control Panel via tweakUI, so
it's just a registry key (I assume).  We could hide the IE one and show the FF
one, but we might just want to show both so MS won't get ****.  Or, we could
just screw this whole idea, unless of course, anyone thinks it's useful now. 
;-)  As you may have noticed, this bug was made pre-1.5 roadmap (afaik), so I
didn't know how to go about a mass installation of extensions, but now, it
should be easy with drag-and-drop into the firefox folder: i.e., write a batch
file to run the ff install, and plop some extensions into the folder after it's
installed.  On the first run, everything is already installed (as far as
extensions go).  Sort of offtopic/rantish here.  Sorry.  Anyone know how to run
the ff install silently?
the switch for silent install, for what its worth, is -ms

We don't really need or want this, marking WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Flags: blocking-aviary2? → blocking-aviary2-
Resolution: --- → WONTFIX
(Reporter)

Comment 6

13 years ago
Fine by me.
You need to log in before you can comment on or make changes to this bug.