Wrong favicons appear on bookmarks for sites with no icon of their own

VERIFIED FIXED in Firefox 3 alpha7

Status

()

Firefox
Bookmarks & History
--
enhancement
VERIFIED FIXED
13 years ago
9 years ago

People

(Reporter: Tomislav, Assigned: thunder)

Tracking

unspecified
Firefox 3 alpha7
Points:
---
Bug Flags:
blocking1.8b5 -
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Icons in Bookmarks are misplaced (see the picture). Sites that do not provide
small icon (icon that appears in top left of the window bar), hava randomly
asigned icons. (BBC has wrong icon - see that "i" icon appears many times, also
"linux today" icon appears twice, once where it should, next time to the wrong
site.)

These icons do not change the place.

Details about configuration:
My bookmarks were imported from Mozilla 1.7.3 (Win). No icons appeared then in
bookmarks. After some browsing, FF added respective icons. In one moment I
realized they are misplaced/copied to wrong places.

Software installation summary: WinXPPro with SP2; Mozilla 1.7.3; FF 1.0; Export
of bookmarks from Mozilla; Import in FF


Reproducible: Always
Steps to Reproduce:
Bug happens allways, but I have no resources to reproduce situation where this
behavior would happen on "clear" instalation. (See "Details" for step I did in
the current instalation.)
Actual Results:  
Icons are misplaced.

Expected Results:  
Icon to be where they should be.

Comment 1

13 years ago
maybe this is bug 174265. 

Did you use any firefox version before using 1.0?

In the mean time to clean up your bookmark file:
In the bookmarks.html file, there are entries ICON which are wrong.
backing up your file, closing all of firefox and removing the wrong ICON tags
will [temporarily?] fix your problem.
(Reporter)

Comment 2

13 years ago
I agree that this is probably a duplicate of bug 174265, but I don't understand
why is that bug marked as "resolved-fixed".

No, I have not used any FF before 1.0; but I have used Mozilla 1.7.3.

PS Sorry for (probably) duplicate bug report, but I had no idea that favorite
icons are called "favicons", so all my searches in database were unsuccessful.

Comment 3

13 years ago
Don't worry about the dupes, you searched for it, and that's more than some
people do ;)

From the discussion in bug 174265 comment 93 and futher i gather that some
people still are having this problem which leads me to believe that the fix
doesn't work for everyone.

What i'll do, is that i confirm this bug, based on your report and several
reports as listed in bug 174265.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 4

13 years ago
This isn't a regression, it was never completely fixed. There's an underlying
issue that needs some significant work, as Vlad indicated in bug 259993 comment 5.

I guess this bug is as good as any to track the outstanding issue...
Keywords: regression

Comment 5

13 years ago
*** Bug 269954 has been marked as a duplicate of this bug. ***
Assignee: vladimir → vladimir+bm
*** Bug 272645 has been marked as a duplicate of this bug. ***
*** Bug 271960 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
Well this isn't fixed at all.
I have been doing some searching in bugzilla and this has been a flaw since
phoenix 0.3 and hasnt been fixed still!

I have tested this on Windows, Linux and a Mac with clean installs of Firefox
1.0 and the bug most certainly exists.

There are a LOT of duplicates of this bug, perhaps this issue (which in my
opinion is a major one) should be added to an FAQ of sorts.

Depends on: 174265

Updated

13 years ago
Summary: Icons in bookmark menu misplaced → Wrong favicons appear on bookmarks for sites with no icon of their own

Comment 9

13 years ago
i have tried to find info on this bug in bugzilla, since it really annoys me in
release 1.0. I haven't seen anyone describe how to reproduce it though, so here
is what happens for me:

i have several sites on my bookmarks toolbar, each with their own favicon. If i
press a bookmark to site A, and site A is down, it will be stuck trying to load
the it for a while. If I, when site A is loading, press the bookmark of site B
in the toolbar, the site B will get the favicon of site A. Doing the same with
sites B, C, D and so on will make the whole toolbar have the same icon for every
site.

this is annoying, since there is no easy way of restoring the icons. hope
someone gets on this issue soon so it is fixed to the next release :>

Comment 10

13 years ago
Created attachment 172797 [details] [diff] [review]
patch to avoid race condition

Quick hack.
Only tested on Firefox 1.0 / Windows 2000, but this may apply current CVS
because code around this bug is not changed recently.

Comment 11

13 years ago
Details for patch 172797:

There is certainly an unexpected calling order of onStateChange(STATE_START) and
updatePageFavIcon().
This patch prevent undesirable change of mFavIconURL in such case.

Imagine the situation; you are loading a page on site A (which has /favicon.ico)
and just before the loading finishes you load another page on site B (which has
no favicon). Calling order is like follwing:

A-1) "onload" event of page on A is invoked.

A-2) updatePageFavIcon() called

A-3) "aBrowser.mFavIconURL = gBrowser.buildFavIconString(uri);" in
updatePageFavIcon()
http://lxr.mozilla.org/seamonkey/source/browser/base/content/browser.js#5527

B-1) onStateChange(..., STATE_START, ...) called
http://lxr.mozilla.org/seamonkey/source/browser/base/content/browser.js#2927
   to start loading of page on B.

B-2) "gBrowser.mCurrentBrowser.mFavIconURL = null;" in onStateChange()
http://lxr.mozilla.org/seamonkey/source/browser/base/content/browser.js#2943

Accidentally, calling sequence A can be done *after* calling sequence B, which
result in incorrect mFavIconURL (which contains URL on site A).

I don't know how to force calling order right.  Instead, this patch do nothing
in updatePageFavIcon() when the browser has already started another page loading.

Comment 12

13 years ago
To test the effect:

1) Prepare two sites which contain one or two files.
SITE A:
+test.html
+favicon.ico
SITE B:
+test.html
(test.html's content is just "<html><head></head><body></body></html>".
favicon.ico can be any icon file whatever you can see it.)

2) Set browser.cache.check_doc_frequency=1 in about:config for convenience.

3) Show bookmarks in sidebar.

4) Bookmark site B's test.html.

5) Load site A's test.html and site B's test.html repeatedly.
(I'll show you a sample script to do this later.)

6) If your Firefox has this bug, you'll see site A's site icon in bookmark after
enough repetition of 5.

Comment 13

13 years ago
Created attachment 173353 [details]
Sample script for Windows

How to use:

Make sure the extension of your downloaded file is ".vbs".

Modify the script.  Change url1 and url2 to your own.
You should set wait1 enough to load whole page of site B.
wait2 is best if you can see A's icon in location bar once every two times on
the average.

Please stop process wscript.exe on task manager to cancel.

Updated

13 years ago
Attachment #172797 - Flags: review?(vladimir+bm)

Comment 14

13 years ago
Created attachment 173466 [details] [diff] [review]
reset mFavIconURL in onLocationChange()

When a new page starts to load while the old one hasn't finished loading yet,
it is possible that mFaviconURL property will be left from the old page, and
then used for the new page in updatePageFavIcon(). mFaviconURL is being reset
to null in several places in the code, however the best place to do it is in
onLocationChange() handler, when the old page should have already finished
loading and can't spoil mFaviconURL anymore.

This patch seems to work for me...
Attachment #173466 - Flags: review?(vladimir+bm)

Comment 15

13 years ago
(In reply to comment #14)
> Created an attachment (id=173466) [edit]
> reset mFavIconURL in onLocationChange()
> 
> When a new page starts to load while the old one hasn't finished loading yet,
> it is possible that mFaviconURL property will be left from the old page, and
> then used for the new page in updatePageFavIcon(). mFaviconURL is being reset
> to null in several places in the code, however the best place to do it is in
> onLocationChange() handler, when the old page should have already finished
> loading and can't spoil mFaviconURL anymore.
> 
> This patch seems to work for me...
> 

This seems to work for me to. When we update Firefox however, the setup will
have to clean out all of those icon tags in the bookmark files so that they
don't stay wrong. I have no idea how this is done but its just something to
remember. Nice work though!
(Reporter)

Comment 16

13 years ago
> This seems to work for me to. When we update Firefox however, the setup will
> have to clean out all of those icon tags in the bookmark files so that they
> don't stay wrong. I have no idea how this is done but its just something to
> remember. Nice work though!

I'm not a Mozilla/FF developer, but may I ask something? If some site changes
the favicon, browser should notice that and change the favicon shown in
bookmarks. If that is the case, Mozilla/FF will notice that favicon is not a
correct one, and it will update it. But I have a feeling that Mozilla/FF does
not try to update favicons in bookmark - or at least it does not check if some
site has lost a favicon (disclaimer: this statement is not an official bug
report). Can anyone confirm my doubts, plz?

Comment 17

13 years ago
"If some site changes the favicon, browser should notice that ... But I have a
feeling that Mozilla/FF does not"

You're right, but that is a different issue to this, and it is already filed as
bug 240795 - let us not confuse the issue here.

Comment 18

13 years ago
(In reply to comment #14)
This patch (attachment (id=173466)) seems to work for me too, though I'm not
sure whether there exists a race condition between onLocationChange() and
updatePageFavIcon()...

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 19

13 years ago
*** Bug 276471 has been marked as a duplicate of this bug. ***

Comment 20

13 years ago
(In reply to comment #18)
> (In reply to comment #14)
> This patch (attachment (id=173466) [edit]) seems to work for me too, though
I'm not
> sure whether there exists a race condition between onLocationChange() and
> updatePageFavIcon()...
> 

It does not matter whether there exists a race condition between
onLocationChange() and updatePageFavIcon(). The problem is that in
updatePageFavIcon() currentURI might be already new, while mPageFavIcon is still
old. We need to reset mFavIconURL to null right after currentURI is changed to a
new uri. currentURI corresponds to mCurrentURI property of docshell, and it is
changed in nsDocShell::SetCurrentURI() -
http://lxr.mozilla.org/seamonkey/source/docshell/base/nsDocShell.cpp#1349. Right
after that SetCurrentURI() fires onLocationChange event. So if reset mFavIconURL
in onLocationChange event handler, we will be set.

Comment 21

13 years ago
Aha! I have figured out how to duplicate this!  It only works with certain sites
though...

Begin loading the bookmark, and just as it is loading, click the other bookmark.
 It happens when you change your mind about which page to load.

Comment 22

13 years ago
*** Bug 290772 has been marked as a duplicate of this bug. ***
*** Bug 292689 has been marked as a duplicate of this bug. ***

Comment 24

12 years ago
*** Bug 296493 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Attachment #172797 - Attachment is obsolete: true
Attachment #172797 - Flags: review?(vladimir+bm)

Comment 25

12 years ago
(In reply to comment #20)
Thanks for reply.  Sorry to be late.
I understood.
In case onLocationChange() before updatePageFavIcon(),
you seem to allow calling updatePageFavIcon() with new URI (not yet loaded), right?
This may cause disregard of a link element in new page and getting /favicon.ico,
which I have not encountered yet :-p.

Oh, the source code around favicons is totally changed by Bug 109672 comment #19.
Examining...

Comment 26

12 years ago
I can't see this bug anymore. Can anyone see it?
Tested on trunk-20050623.
*** Bug 291015 has been marked as a duplicate of this bug. ***
*** Bug 291091 has been marked as a duplicate of this bug. ***

Comment 29

12 years ago
I confirm this bug is still here
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050713
Firefox/1.0+ ID:2005071314
Comment on attachment 173466 [details] [diff] [review]
reset mFavIconURL in onLocationChange()

bumping to the right vlad account
Attachment #173466 - Flags: review?(vladimir+bm) → review?(vladimir)

Updated

12 years ago
Flags: blocking-aviary1.1? → blocking1.8b4+
Attachment #173466 - Flags: review?(vladimir) → review+
Attachment #173466 - Flags: approval1.8b4?
Comment on attachment 173466 [details] [diff] [review]
reset mFavIconURL in onLocationChange()

a=shaver.
Attachment #173466 - Flags: approval1.8b4? → approval1.8b4+
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Whiteboard: [ready to land]

Comment 32

12 years ago
Vladimir landed this when he marked it fixed earlier today
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-07-27+07%3A19&maxdate=2005-07-27+07%3A19&cvsroot=%2Fcvsroot
Whiteboard: [ready to land]

Comment 33

12 years ago
I think the submitted patch has bitrotted.

As mentioned in comment #20, the favicon handling has been changed quite a lot
over in bug 109672.

mFavIconURL is no longer used. The variable is now called mIconURL. So AFAICS
the patch does nothing apart from setting an unset variable.

Resetting of mIconURL is already done further up in onLocationChange in the call
to gBrowser.setIcon(). When the browser is in tabbed mode, the resetting is done
in the onLocationChange handler in tabbrowser.xml.

So I suggest backing out the patch.

What may be the problem, though, is that BookmarksUtils.loadFavIcon() is only
called if a favicon is actually found. This prevents us from resetting an icon,
if the favicon for a given site disappears (or if a wrong favicon was stored in
the bookmark file because of a bug in Firefox, e.g. the now fixed bug 109672).

Yani: do you see the problem with newly created bookmarks, or is it only old
bookmarks (from before bug 109682 was fixed) that have weird icons?

Comment 34

12 years ago
REOPENING

I suggest that the patch is backed out.

I am pretty sure that the patch that was committed does not do anything. Note
that the patch was made before the major changes done by bug 109672, so it may
very well have worked at the time it was submitted.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Vlad?
Assignee: vladimir+bm → vladimir
Status: REOPENED → NEW

Comment 36

12 years ago
I read all the corresponding above, but since im not as an experienced FF user
as you guys :-) , i'll just enter the problem i encountered hoping it really is
related to the bug mentioned here (please forgive me if its not related and i
miss understood).

when trying to add the following URL to my bookmarks, the sites icon does not
appear: www.lionetwork.net
obviously, in IE it does work...

I'm using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6

This happened before upgrading to 1.0.6 (previously 1.0.5) - and i had a "fresh"
install of FF.

Comment 37

12 years ago
(In reply to comment #33)

> Yani: do you see the problem with newly created bookmarks, or is it only old
> bookmarks (from before bug 109682 was fixed) that have weird icons?

The problem is still present with old bookmarks.
I will try with newly created ones.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050809
Firefox/1.0+

Comment 38

12 years ago
The problem is present with newly created bookmarks too !

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050811
Firefox/1.0+

Comment 39

12 years ago
This bug seems to be fixed :
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050816
Firefox/1.0+ (bangbang023).

Comment 40

12 years ago
hum,please ignore my comment #39
Created attachment 193206 [details] [diff] [review]
updated patch for branch & trunk

I can't reproduce this still (with or without the script); however, I can
update the previous patch to change the variable name...
Attachment #193206 - Flags: review?(mconnor)

Comment 42

12 years ago
Vladimir: Are you sure this fixes the problem?

As mentioned in comment 33, mIconURL is already reset further up in
onLocationChange or, when the browser is in tabbed mode, in onLocationChange in
tabbrowser.xml.


Yani: do you see the problem both with and without tabbed mode? (You are not in
tabbed mode if you open a Firefox window with the tab bar hidden (you may have
to change your prefs to make this happen). You enter tabbed mode when the tab
bar is shown for the first time (and you don't leave it before you close the
window, even if the tab bar gets hidden again))
Severity: normal → enhancement

Comment 43

12 years ago
> Yani: do you see the problem both with and without tabbed mode? (You are not in
> tabbed mode if you open a Firefox window with the tab bar hidden (you may have
> to change your prefs to make this happen). You enter tabbed mode when the tab
> bar is shown for the first time (and you don't leave it before you close the
> window, even if the tab bar gets hidden again))

The bug happens only in the bookmarks toolbar.
When I open a bookmark with wrong favicon in new tab or new window,the correct
icon is shown.

Comment 44

12 years ago
(In reply to comment #38)
Yani,
Can you show us URL of your problematic bookmarked page and URL of the appearing
favicon and, if you can, steps to reproduce the problem?

Updated

12 years ago
Whiteboard: [needs review mconnor]

Comment 45

12 years ago
(In reply to comment #44)
> (In reply to comment #38)
> Yani,
> Can you show us URL of your problematic bookmarked page and URL of the appearing
> favicon and, if you can, steps to reproduce the problem?

I have several wrong favicons.
But,for example : 
http://bakkap.free.fr/ shows correct favicon but it shares it with
http://www.menuetos.org/ (this site doesn't have favicon).
I have this problem with several sites.
read description of bug here : https://bugzilla.mozilla.org/show_bug.cgi?id=291091
I don't know if it is reproducible.

Updated

12 years ago
Attachment #193206 - Flags: review?(mconnor) → review+

Comment 46

12 years ago
Comment on attachment 193206 [details] [diff] [review]
updated patch for branch & trunk

Oh, no. You should not check-in this patch. I'd suggest that you simply back out
the previous patch.
This patch will make following regressions.
1. Start Firefox.
2. Go to http://www.nasa.gov/externalflash/m2k4/frameset.html
   (It has own site icon.)
3. Open New Tab.
4. Back to the first tab.
5. You'll see default icon on location bar.
Another case:
1. Start Firefox.
2. Go to http://www.nasa.gov/externalflash/m2k4/frameset.html
   (It has own site icon.)
3. Click CREDITS in the bottom of the page.
4. Open New Tab.
5. You'll see default icon on the first tab.

Updated

12 years ago
Whiteboard: [needs review mconnor]
Attachment #193206 - Attachment is obsolete: true
Attachment #173466 - Attachment is obsolete: true

Comment 47

12 years ago
(In reply to comment #45)
Hmm... I can't reproduce. Things must be more specific.
* All wrong favicons you have are from pages which have LINK elements (<link
rel="icon" href="...">), aren't they?
  Do you still have a Google favicon in wrong place?
* (What mentioned in comment #42 is,) were you using two or more tabs when you
got a wrong favicon?

> The bug happens only in the bookmarks toolbar.

How about Bookmarks menu? Check Bookmarks > Bookmarks Toolbar Folder.

Comment 48

12 years ago
(In reply to comment #47)
> Hmm... I can't reproduce. Things must be more specific.
> * All wrong favicons you have are from pages which have LINK elements (<link
> rel="icon" href="...">), aren't they?
>   Do you still have a Google favicon in wrong place?
> * (What mentioned in comment #42 is,) were you using two or more tabs when you
> got a wrong favicon?
> 
> > The bug happens only in the bookmarks toolbar.
> 
> How about Bookmarks menu? Check Bookmarks > Bookmarks Toolbar Folder.

Yes,it is. (That's the only way of having a favicon).
Yes,I still have a google favicon in wrong place.
When opened in a tab,correct favicon is shown (no matter how many tabs are opened).
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050827
Firefox/1.6a1 (bangbang023) ID:0000000000
Yes,it is present in the bookmark menu too.
Note that once a bookmark gets a wrong favicon, it'll stay that way permanently
-- so to reproduce this we need a way to actually have a bookmark get the wrong
favicon (change from no favicon to a wrong one), as opposed to just having the
wrong one show up.

Comment 50

12 years ago
This is quite possibly a completely redundant comment, however I seem to
remember this problem occurring to me when:

1. You've been to site A before, and bookmarked it (having it's own favicon)
2. You try to go to site A again, but the connection's going to time out, the
server's not responding.
3. Before the connection is broken, you change your mind and click on the
bookmark to site B (which has no favicon).
4. Site B now miraculously has Site A's favicon...

Comment 51

12 years ago
I can reproduce with SeaMonkey/2005090205-trunk/WinXP.

Screen shot:
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=2895&action=view

Comment 52

12 years ago
(In reply to comment #51)
The relevant code of SeaMonkey is very different from Firefox's.
Calling sequence is like following. It looks like former Firefox's
implementation, but I'm not convinced.
icon image onload event > HandleBookmarkIcon() > UpdateBookmarkIcon() >
ProcessCachedBookmarkIcon()

I think this bug is for Firefox. How about creating another bug?

Comment 53

12 years ago
(In reply to comment #52)
Nishimura-san, thank you for comment.

> I think this bug is for Firefox. How about creating another bug?
I reported in bug 307692.

Comment 54

12 years ago
Vladimir,
The bogus mFavIconURL still appears on trunk.
http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#3500
(On 1.8 branch it was backed-out already in 1.479.2.18.)

Yani,
I'm still lacking for some information to reproduce...
Can you show me how to reproduce in detail, please? How did you create new
bookmarks? Can you reproduce with newly created profile?

Comment 55

12 years ago
(In reply to comment #54)
> Yani,
> I'm still lacking for some information to reproduce...
> Can you show me how to reproduce in detail, please? How did you create new
> bookmarks? Can you reproduce with newly created profile?

I don't know if it is reproductible.
All I know is that I bookmarked 2 some sites in bookmarks toolbar folder,and
some of them (that haven't their own favicon) steals favicons from other sites.

I tried to reproduce it with a fresh profile with build :
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050910
Firefox/1.6a1 (bangbang023)

I bookmarked in the bookmarks toolbar folder 2 sites : one with favicon,other
without.
Firefox doesn't show me any favicons at all (other than default favicon).

I will test tomorrow with a fresher build.

Updated

12 years ago
Flags: blocking1.8b5+ → blocking1.8b5-

Comment 56

12 years ago
I have seen that the method was mentioned before (start loading a page and then
switch), but nobody has mentioned that the favicon of the bookmark not only
changes in the BTB (bookmark toolbar), but also in the address bar.  This tab,
opened in a new window thanks to gmail doing that by default, has the default
icon in the tab but the dinohead in the address bar.

I noticed it while gMail was doing its 'loading', although I was just switching
between messages, and then I went to my bookmark for lingo.com.  Almost
instantly, lingo loaded with the gmail icon in both addressbar and tab bar.  I
switched tabs to open a bugzilla tab before taking a screenshot, and switched
back.  Lingo retained both icons, in address and tab bar, from gmail.  I hit alt
home (I meant to hit Fn Home, for Print Screen) and Firefox went to Firefox
Start.  I hit back, and Lingo no longer had the gmail icons.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915
Firefox/1.0.7

Comment 57

12 years ago
*** Bug 313495 has been marked as a duplicate of this bug. ***

Comment 58

12 years ago
The little website icons that can be found to the left of each bookmark
propagate wrongly (and have been before version 1.0 of firefox). Most websites
dont even LOAD their icon, and when a wensite does, an icon gets "stuck" where
several bookmarks you open afterwards will all get its icon (which is not their
icon).

There is also an apperant constant inflation in the size of the bookmarks file.
So I suspect there is some junk in there.

Reproducible: Always

Steps to Reproduce:
1. Open a website from a bookmarked folder
2. If the bookmark changes to include an icon, open other websites and observe
how their icon changes to match the first's
If the bookmark does NOT change to show their icon, its still a bug (just a
different one). Most of the time it does not change, sometimes it changes
multiple ones to the wrong icon...

Actual Results:  
Wrong Icons

Expected Results:  
Load the correct icon for every page every time it is opened. Remove current
icon of said page does not contain an embedded icon.

Comment 59

12 years ago
What can I say ...
The problem is still here.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051101 Firefox/1.6a1

Comment 60

12 years ago
isnt it possible to make a workaround? I understand that the issue runs very deep and has thus evaded solution since before the days of version 1.0
But a workaround that treats the symptoms will be welcome until an actual solution is found

Comment 61

12 years ago
If it helps here's another example to reproduce this bug. I can only reproduce this with this particular jump-off site, not others. The result is that all my bookmarks in bookmarks toolbar folder which had no favicon assigned inherit, in this case, the betfair favicon!

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Go to www.betfair.com, bookmark the site in bookmarks toolbar folder
Go to www.popbitch.com (has no favicon), bookmark in bookmarks toolbar folder
Click www.betfair.com bookmark, and before site has fully loaded click on popbitch  bookmark - popbitch favicon gets set as betfair's.

Comment 62

12 years ago
(In reply to comment #61)
Can you test on Firefox 1.5 RC 1 or later, please? The code around favicons was totally changed.

Comment 63

12 years ago
Apologies. It looks good with both 1.5rc1 & 1.5rc2 - I can't reproduce this at all now.

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.8) Gecko/20051107 Firefox/1.5

Comment 64

12 years ago
is there a fav icon cleaner available?

Even if it no longer incorrectly assigns the wrong icons. My list is already full of wrong icons. Is there a way to "dump" ass existing icons and convert my bookmarks into the new format? (I use the same bookmarks file I created in version 1.0 beta). Needless to say I cannot just scrap it all (hundreds of links)

Comment 65

12 years ago
I meant to type "dump ALL icons" not "dump ASS icons". Sorry about that. Blind typing...
(In reply to comment #64)
> is there a fav icon cleaner available?
> 
> Even if it no longer incorrectly assigns the wrong icons. My list is already
> full of wrong icons. Is there a way to "dump" ass existing icons and convert my
> bookmarks into the new format? 
see bug 257791

Comment 67

12 years ago
I have used bookmark synchronizer to recreate my bookmarks WITHOUT any icons. (export without icons... and then import overwriting the current bookmarks).

Since then I have not had any icon incogruities (they all load correctly) using version 1.5 rc2

Comment 68

12 years ago
(In reply to comment #67)
> I have used bookmark synchronizer to recreate my bookmarks WITHOUT any icons.

I think it would be useful to have an option to refresh favicons in the bookmark manager. :)

Comment 69

12 years ago
oop... Ok, I just got my first wrong fav icon.

It seems that with the new improvements wrong icons are much RARER. But can still occur.

While I dont get wrong icons ALL the time. I did get one when a page failed to load (I dont remember what exactly happened, there was an error of sorts, and it got stuck with another page's icon)

Comment 70

12 years ago
"oop... Ok, I just got my first wrong fav icon."  - correction.. my first wrong fav icon since updating and clearing my bookmarks

Comment 71

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051231 Firefox/1.6a1 
The behavior is still here.
Someone is working on this ?
*** Bug 330173 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
*** Bug 317131 has been marked as a duplicate of this bug. ***

Comment 75

11 years ago
*** Bug 364778 has been marked as a duplicate of this bug. ***

Comment 76

11 years ago
This has been here for so long :(
Please can somebody fix this

Comment 77

11 years ago
And why is this marked as "enhancement", it's clearly a bug

Comment 78

11 years ago
you can tempory fix this..

go to about:config
search browser.chrome.favicons
set the value to FALSE

restart your browser and change it back to true

i think i fixed that, but it was tempory! 

Updated

11 years ago
Flags: blocking-firefox3?

Comment 79

11 years ago
I'm getting the wrong favicon even for sites that DO have one.  Seems like firefox has been doing this FOREVER.
Marking as blocking, need to retest once Places bookmarks are enabled.
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Assignee: vladimir → thunder

Updated

10 years ago
Target Milestone: --- → Firefox 3 alpha6
Dan, I'm moving this out, but please check into this and resolve if its fixed on trunk.
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1

Comment 82

10 years ago
I have seen this regularly with Firefox 2, but I don't think this is a problem with trunk builds anymore (places-bookmarks was turned on for Gran Paradiso Alpha 5).
(Assignee)

Comment 83

10 years ago
I've tried to repro this by hand and by running the script, and I haven't seen any wrong icons.  Resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → FIXED
verified with:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071805 Minefield/3.0a7pre

With the given url, the location bar favicon and tab favicon have a compressed view of the page itself. The added bookmark of the page has the blank page icon for the favicon.  I believe this is all as expected.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.