-moz-border-radius doesn't work with any other border style but solid

RESOLVED DUPLICATE of bug 13944

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 13944
14 years ago
14 years ago

People

(Reporter: jan klopper, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Gecko (and thus firefox) doesn't render any css border-type other than solid
correct when aplying a -moz-border-radius on it.

I think gecko should be able to draw at least the dashed border style when using
the -moz-border-radius option.
If we are going to support css3, (even trough extra css tags, lets at least
support the whole branch.)
I realize drawing any other border style but solid while using the radius opton
is harder than just drawing the square border but it can't be difficult enough
not to be implemented.

Reproducible: Always
Steps to Reproduce:
1.create a div, and give it a dashed border, and a noticable background-color
trough it style tag.
2.not add -moz-border-radius to it, and notice that the border-style is rendered
as if it was set to solid.

Actual Results:  
i got a div with its border rounded, but not a dashed border like i requested.

Expected Results:  
given me a rounded div, with a dashed border instead of solid border.

*** This bug has been marked as a duplicate of 13944 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.