Hover not unhovered when background-attachment: fixed; is set and when going into browser chrome

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows 2000
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
See upcoming testcase.

This seems like a regression.
It doesn't happen with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20040930
Firefox/0.9.1+ 7:52am
But it happens with:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041001
Firefox/0.9.1+ 7:33am

Bonsai link:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-09-30+07%3A00%3A00&maxdate=2004-10-01+08%3A00%3A00&cvsroot=%2Fcvsroot
(Reporter)

Comment 1

14 years ago
Created attachment 166853 [details]
Testcase

Comment 2

14 years ago
(In reply to comment #1)
> Created an attachment (id=166853)
> Testcase
> 
Testcase works as expected in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Hmmm... In that range, the patch for bug 191151 is a possible culprit (though
it's a stretch), and nothing else looks really relevant.

Martijn, do you possibly have time to narrow down the checkin responsible?
(Reporter)

Comment 4

14 years ago
Ok, I've build a 2004-09-29 trunk build, which doesn't have the bug. After that
I applied the patch from bug 191151, and rebuilt the layout part (in
mozilla/layout do a make). After that I still can't see the bug. So the fix for
bug 191151 doesn't seem to be the cause.
Maybe I'm a bit too narrow with the regression times?
(Reporter)

Comment 5

14 years ago
I now have applied the patch from bug 258910 and rebuild the entire tree, after
that I can see the bug, so I guess the fix for bug 258910 is responsible.
Better I'll warn the patch author, then. ;)
Depends on: 258910
If I put the background struct check after the color struct, the bug disappears,
presumably because we bail out before ever getting to the background struct.

If I remove the color change from the testcase, however, I see the problem in a
2004-09-30 build as well.  So that patch just exposed this underlying bug on
that particular testcase (by putting the background struct before the color
struct, where it belongs).
Created attachment 168036 [details]
Testcase that shows bug in older builds too
Attachment #166853 - Attachment is obsolete: true
Does the patch that was just checked in for bug 284664 fix this, by any chance?
(Reporter)

Comment 9

13 years ago
Yep, seems to be working now in 2005-03-29 build. Marking WFM, almost certainly
fixed by bug 284664
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.