Can't open local files with non-ASCII characters in the path

VERIFIED DUPLICATE of bug 263570

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 263570
14 years ago
14 years ago

People

(Reporter: Anton Gavrilov, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

E.g. when trying to open "C:\Documents and Settings\User\Рабочий стол\test.htm", 

I get "The file /c:/Documents and Settings/Admin/%D0%E0%E1%EE%F7%E8%E9%
F1%F2%EE%EB/test.htm cannot be found. Please check the location and try again."

Essentially this means that e.g. on the Russian version of Windows, Firefox
fails open ANY document from the desktop or the My Documents folder, because
both folders have cyrillic letters in the path.


Reproducible: Always
Steps to Reproduce:
1. Save a web page onto the desktop. Any page.
2. Try to open it
(Reporter)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 263570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.