If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

International characters ruin the rest of subject line with question marks

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Frank Fridlund, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Thunderbird chokes with a message when a character from a different language
(such as the Swedish å) if it appears in the subject line.  The rest of the
subject line is filled with question marks.  This is only a display problem as
the subject itself is unaltered, but one that will annoy international users. 
The problem is seen not only in the list, but above the preview window.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
I think it could be due to incorrect character enconding in the mail message.
Reporter, could you submit a testcase?
(Reporter)

Comment 2

13 years ago
I think you're right.  It works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 3

13 years ago
(In reply to comment #2)
> I think you're right.  It works for me.

Feel free to reopen this bug if you see it again.

You need to log in before you can comment on or make changes to this bug.