Last Comment Bug 27162 - Default link target should be most recently used browser
: Default link target should be most recently used browser
Status: RESOLVED WONTFIX
:
Product: SeaMonkey
Classification: Client Software
Component: Sidebar (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 27161
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-09 17:06 PST by Steve Lamm
Modified: 2010-12-22 09:47 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Steve Lamm 2000-02-09 17:07:00 PST
Currently, sidebar content developers have to set the default link target to 
"_content". Otherwise, link will replace the sidebar content. The default should 
be to load in the main browser window or the most recently used browser. 

Once this new default is used, content developers can use the "_self" target to 
replace the sidebar content if they want.
Comment 1 Paul MacQuiddy 2000-03-05 23:43:22 PST
I think this bug needs to get fixed now that 27161 has been fixed, since you 
still have to set target= "_content" so marking beta1
Comment 2 leger 2000-03-06 17:29:55 PST
PDT need more info on how this affects the end user please.  Does this affect 
3rd party ability to add contect to the sidebar?
Comment 3 Phil Peterson 2000-03-07 17:55:07 PST
PDT-
Comment 4 don 2000-04-06 14:10:59 PDT
Move to M16 ...
Comment 5 Paul MacQuiddy 2000-04-13 00:39:43 PDT
spam: changing qa contact on sidebar bugs from paulmac to shrir@netscape.com 
(all 67 of them!)
Comment 6 don 2000-05-25 16:14:11 PDT
Move to M20 target milestone.
Comment 7 Blake Ross 2000-11-11 20:09:04 PST
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Comment 8 Jesse Ruderman 2000-12-12 22:25:10 PST
ns6 has been out for a while.. probably too late to change this.
Comment 9 Viswanath Ramachandran 2001-01-30 11:12:26 PST
descheduling this from matt's 0.9 plate. lowering priority and moving to 
mfuture. doing this to make room for 55052 new on the nsbeta1 list. 
Comment 10 shrirang khanzode 2001-01-31 20:23:42 PST
spam : changing qa to sujay (New Sidebar QA)
Comment 11 Jesse Ruderman 2001-04-08 15:22:53 PDT
Nominating for mozilla0.9.  This is important if users are going to be able to 
add arbitrary pages as sidebar tabs (bug 50063).

Disagreeing with what I said a few months ago: fixing this bug probably won't 
break a lot of existing sidebars, since not many sidebars try to load 
additional content in the sidebar after the user clicks on a link.

See also bug 50748, "mail sidebar links open a NEW browser window EVERY time".
Comment 12 Viswanath Ramachandran 2001-04-13 13:41:21 PDT
nav triage: in fact, we should be careful about changing the default behaviour, 
because there may be tabs out there that assume that no target => the target is 
self. we probably should just keep this behaviour in the interests of backward 
compatibility. matt, do you think we should WONTFIX the bug? 
Comment 13 Jesse Ruderman 2001-04-22 01:15:52 PDT
This bug indirectly caused bug 65625, "Edit button in Sidebar 'Stocks' tab does 
not work", which is nsbeta1+.  (There is a workaround for that problem, but it 
took three months to figure out what the problem was.)
Comment 14 Blake Ross 2002-02-03 00:53:14 PST
-> default owner
Comment 15 Bogdan Stancescu 2004-01-15 15:49:51 PST
Will there be any anniversary on the 9th? :)
Comment 16 Robert Kaiser 2009-06-14 07:00:42 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 17 Robert Kaiser 2009-06-14 07:04:17 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 18 Robert Kaiser 2009-06-14 07:10:05 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 19 Robert Kaiser 2009-06-14 11:52:03 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 20 Robert Kaiser 2009-06-14 14:47:22 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 21 Robert Kaiser 2009-06-14 15:09:17 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 22 Robert Kaiser 2009-06-14 15:14:31 PDT
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Comment 23 Robert Kaiser 2010-04-28 13:33:27 PDT
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Comment 24 Karsten Düsterloh 2010-12-22 09:47:48 PST
Not changing the default behaviour after over ten years without any striking reasons.

Note You need to log in before you can comment on or make changes to this bug.