If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ability to download attached files in email (such as Yahoo) is inconsistent. OK button is greyed out.

RESOLVED EXPIRED

Status

()

Toolkit
Downloads API
--
major
RESOLVED EXPIRED
13 years ago
9 years ago

People

(Reporter: Jim Jutte, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

When using FireFox at sites such as Yahoo, if I attempt to download attachments,
the success rate is approximately 50%. The problem that I see is that this is
not dependent on file type. For example, one time a .doc file will download
fine, the next time, it will not. The absence of a file extension also does not
seem to be the issue. These are again about 50% of the time downloaded without
issue.



Reproducible: Sometimes
Steps to Reproduce:
1. login to Yahoo
2. follow steps to download a file attached to email
3. the OK button will be faded if the problem is reproduced and the file cannot
be downloaded.

Actual Results:  
Nothing... I cannot proceed further. I have to use IE 6.0. For some reason this
NEVER happens with IE.

Expected Results:  
The OK button should have been available, and a download possible.

I consider this bug major because it forces the user to use another software in
order to proceed with a fairly standard process.

It renders this part of the software useless.

Comment 1

13 years ago
WFM (Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040913 Firefox/0.10) in
Novell Linux Desktop.

Comment 2

13 years ago
(In reply to comment #0)
> [...] For example, one time a .doc file will download
> fine, the next time, it will not. 

Do you mean exactly the *same* file (in a second or third try) or another
attachment with the same extension?

> 3. the OK button will be faded if the problem is reproduced and the file cannot
> be downloaded.

Maybe related to bug #264492 -- even your problem sounds a little bit different
(especially that the behavior is not 100% reproducable for a specific kind of file).

Maybe the MIME-type (which is related to the file-extension, but not the same)
Yahoo sends with the file/attachment differs (just a wild guess to explain the
undeterminated behavior).

Another explantion: The application you have chosen for a kind of file at the
time of the last download is not available anymore (temporary or permanent) -
for example because the application is on a network share which is not always
mounted.

Anyway: It is a bug -- and I my opinion more and more people will run into it,
because environment envolves (applications are replaced and updated...). And
hacking the profile is no solution for average experienced users.

Maybe following steps help getting rid of the bug (if you are technical
experienced or a brave person): 
1) Backup your profile just for the case that something goes wrong.
2) Take a look in the file mimeTypes.rdf in your profile and check the path to
the applications listed in there (this file looks scary for non-technical
users). If paths are outdated, it is very likely that your bug is a duplicate of
bug #264492.
3) Test if the bug still occurs
4) As a last resort rename or delete mimeTypes.rdf in your profile. You will
lose all associations between application and type of file/extension.

Prevention:
Avoid keeping "do this automatically for files like this from now on" unchecked
in the download manager until the bug is fixed.
(Reporter)

Comment 3

13 years ago
It may be that the "application" that it's looking for might be the problem 
because I update the OpenOffice app on a regular basis. I'll see if this 
happens if I update OpenOffice, uninstall FireFox, reinstall FireFox... Sorry 
for the delay. It will a day or two to confirm this... but I think we're onto 
something that might allow fixing the bug.
(Reporter)

Comment 4

13 years ago
That wasn't it. I downloaded and installed OpenOffice 1.1.4RC, then downloaded
the German version of  Firefox 1.0.

I then tried to download an MS-Word Document sitting in my yahoo account and got
the same thing.

Cheers

Comment 5

13 years ago
(In reply to comment #4)
> I then tried to download an MS-Word Document sitting in my yahoo account and got
> the same thing.

1) You installed OpenOffice/Firefox on a new machine (without Firefox/OpenOffice
ever installed) or just uninstalled/re-installed?

==> If you uninstall/re-install Firefox, this may not help (especially if your
problem is caused by bug #264492), because your profile - which contains
bookmarks and other settings - is not deleted on uninstall (after reinstallation
you have the same profile -- and if there's something wrong in there...).


2) What do you mean with "the same thing"?
==> If you want to download a *specific* ".doc" file from a *specific* email,
you can't download this file
a) always (but other ".doc" files from other attachment can be downloaded always)
b) only sometimes (non-reproducible), so the same file sometimes works -
sometimes not


........


What else can you do?
To make sure that this bug is not a duplicate, please open you profile:

==> Click Start > Run..., enter %AppData%\Mozilla\Firefox  and press Enter. You
will be taken to the "real" folder, which is normally C:\Documents and
Settings\[UserName]\Application Data\Mozilla\Firefox (slighly different for
localized windows versions).

There should be a single folder containing three random letters "xyz"
("default.xyz"). And in this folder there is this "ominous" mimeTypes.rdf file
as described in bug #264492 report.

Close Firefox, rename this file (e.g. mimeTypes.old), start Firefox again.

Now check if your problem still persists.

If it does not work, you can restore your original profile: Delete the
mimeTypes.rdf created by Firefox, rename your old file mimeTypes.old back to
mimeTypes.rdf.

What's the mimeTypes.rdf for?
--> This file is used as a persistent data store for helper application information.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.