Closed Bug 271626 Opened 15 years ago Closed 15 years ago

Save Page As... Web Page, complete - doesnt save css files imported by css files

Categories

(Toolkit :: Downloads API, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: scottpboyd, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

This webpage, flexible-layout - uses several css files.  The main html page
includes a <link> to screen.css, which imports other css files.
 (e.g. @import url(layout.css);)

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.webproducer.at/flexible-layout
2. File --> Save Page As... --> 
3. Save as Type "Web Page, complete"

Actual Results:  
C:\Flexible Layout\firefox>dir /s

 Directory of C:\Flexible Layout\firefox

11/24/2004  05:37p      <DIR>          .
11/24/2004  05:37p      <DIR>          ..
11/24/2004  05:37p              12,025 flexible-layout.htm
11/24/2004  05:37p      <DIR>          flexible-layout_files
               1 File(s)         12,025 bytes

 Directory of C:\Flexible Layout\firefox\flexible-layout_files

11/24/2004  05:37p      <DIR>          .
11/24/2004  05:37p      <DIR>          ..
11/24/2004  05:37p                  82 screen.css
               1 File(s)             82 bytes

     Total Files Listed:
               2 File(s)         12,107 bytes
               5 Dir(s)   1,846,693,888 bytes free

Expected Results:  
Compare results to IE6 - note that 6 files were downloaded


C:\Flexible Layout\ie>dir /s

D Directory of C:\Flexible Layout\ie

11/24/2004  05:34p      <DIR>          .
11/24/2004  05:34p      <DIR>          ..
11/24/2004  05:34p               9,291 Flexible Layout.htm
11/24/2004  05:34p      <DIR>          Flexible Layout_files
               1 File(s)          9,291 bytes

 Directory of C:\Flexible Layout\ie\Flexible Layout_files

11/24/2004  05:34p      <DIR>          .
11/24/2004  05:34p      <DIR>          ..
11/24/2004  05:34p               2,318 elements.css
11/24/2004  05:34p                 562 ie.css
11/24/2004  05:34p                 977 layout.css
11/24/2004  05:34p               2,180 presentation.css
11/24/2004  05:34p                  92 screen.css
               5 File(s)          6,129 bytes

     Total Files Listed:
               6 File(s)         15,420 bytes
               5 Dir(s)   1,846,693,888 bytes free


I did not test, but this could affect other files included by css files (e.g.
background images)

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.