84-97% CPU Usage after dialup disconnect.

RESOLVED DUPLICATE of bug 213637

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 213637
15 years ago
8 years ago

People

(Reporter: josh_morris_84, Assigned: bugzilla)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041115 Firefox/1.0

After getting a disconnect from my dialup service and then reconnecting and then
resume using the same Firefox instance that was used before the disconnect, I
get around an 84-97% CPU usage that will not go down. I then have to exit
Firefox and restart it. The problem appears to be in the disconnect and not the
reconnect.

Reproducible: Always
Steps to Reproduce:
1.Disconnect from service either manually or by accident (problem may only work
with dialup)
2.Take a glance at the CPU usage in the processes list.

Actual Results:  
84-97% CPU Usage that will not go down.

Expected Results:  
...I think it's pretty obvious what it should have done.

I am using the Noia 2.0 eXtreme Theme Version 2.79 but I believe the bug still
happens with any theme.

System Specs.
XP Home Service Pack 2
P3 Celeron 566MHZ
320MB SDRAM
nVidia Geforce4 MX 440 SE Driver Version 70.41 Beta
(Reporter)

Comment 1

15 years ago
...Me again. The cause for it appears to be Norton AntiVirus 2004 Pro. After I
installed Norton AntiVirus 2005, it appears to not do this anymore.
Marking as WORKSFORME. Reopen if the problem appears again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
...Nevermind, it still happens.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

14 years ago
I confirm this bug. 
The bug is not reproducible always for me, just in about 50% of cases. 
Screenshot of Proccess Explorer Threads view (maybe will make any sense? I'm not
a programmer..): http://img259.echo.cx/img259/3087/ff100cpuload1ls.png

Comment 5

14 years ago
After a disconnect if I set FF to offline mode, the CPU activity ceases. But as
soon I go back online FF continues to waste CPU time, even after a reconnect. 

Comment 6

14 years ago
This bug is haunting me again and again :( Fix it please.

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 240759 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE

Comment 8

13 years ago
I have Firefox 1.5.0.2 on Windows and this problem not solved.'
When I disconnect from Internet firefox start using 100% CPU. When I choose "Work offline" FF stop using CPU so mach. But when connection to Internet is up and I choose to "Work online" FF start using 100% CPU again.
Please reopen this bug.

Comment 9

13 years ago
(In reply to comment #8)
> I have Firefox 1.5.0.2 on Windows and this problem not solved.'
> When I disconnect from Internet firefox start using 100% CPU. When I choose
> "Work offline" FF stop using CPU so mach. But when connection to Internet is up
> and I choose to "Work online" FF start using 100% CPU again.
> Please reopen this bug.

1) Does it happen with the latest trunk (http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/pacifica-trunk/)?
2) Do you have any FF extensions installed?
3) Does it happen under the safe mode of FF?

Comment 10

13 years ago
(In reply to comment #9)

> 1) Does it happen with the latest trunk
> (http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/pacifica-trunk/)?

Don't know. Sorry.

> 2) Do you have any FF extensions installed?

No one.

> 3) Does it happen under the safe mode of FF?

How can I start FF in safe mode? 

Comment 11

13 years ago
(In reply to comment #10)
> > 3) Does it happen under the safe mode of FF?
> 
> How can I start FF in safe mode? 

Start Menu -> Programs -> Firefox -> Firefox (Safe Mode)

Anyway unless you try the latest trunk or branch there's little chance you get help in a short time...

Comment 12

13 years ago
I have installed 1.5.0.3 version and this bug still present.

1. Start FF. CPU usage is normal.
2. Connect to internet (dial-up).
3. Open some website.
4. Disconnect from Internet.
5. FF start using 100% CPU.
6. Connect to Internet again.
7. FF still using 100% CPU.
8. Switch to "Offile mode" in FF, and FF stop using 100% CPU.
9. Switch to "Online mode" and FF start using 100% CPU.

I have not extentions. Installed only native FF.
I have Windows XP SP2 without any updates.

Comment 13

13 years ago
(In reply to comment #12)
> I have installed 1.5.0.3 version and this bug still present.
> 
> 1. Start FF. CPU usage is normal.
> 2. Connect to internet (dial-up).
> 3. Open some website.
> 4. Disconnect from Internet.
> 5. FF start using 100% CPU.
> 6. Connect to Internet again.
> 7. FF still using 100% CPU.
> 8. Switch to "Offile mode" in FF, and FF stop using 100% CPU.
> 9. Switch to "Online mode" and FF start using 100% CPU.
> 
> I have not extentions. Installed only native FF.
> I have Windows XP SP2 without any updates.
> 

Reopening.
How about Safe Mode?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

13 years ago
Keywords: hang

Comment 14

13 years ago
*** Bug 287994 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
This might be identical to bug 327050 which has some additional information in it. It's not specific to dialup, however, but any network connection.

Comment 16

13 years ago
Do you guys with this problem have any firewall software working background? Comment #1 suggests it's one of the sources for this bug.

Comment 17

13 years ago
I have two machines on which I can reproduce this (actually, three). One is running Windows firewall in its default configuration, the other runs ZoneLabs Integrity.

On the latter, I turned off both firewalls and re-tested. Same thing happens.

Both machines also have different AntiVirus software (Symantec & Avast). If I disable Avast, no difference. (I can't disable Symantec, but there's no evidence to suggest it's the culprit at this point.)

Comment 18

13 years ago
(In reply to comment #13)
> (In reply to comment #12)
> > I have installed 1.5.0.3 version and this bug still present.
> > 
> > 1. Start FF. CPU usage is normal.
> > 2. Connect to internet (dial-up).
> > 3. Open some website.
> > 4. Disconnect from Internet.
> > 5. FF start using 100% CPU.
> > 6. Connect to Internet again.
> > 7. FF still using 100% CPU.
> > 8. Switch to "Offile mode" in FF, and FF stop using 100% CPU.
> > 9. Switch to "Online mode" and FF start using 100% CPU.
> > 
> > I have not extentions. Installed only native FF.
> > I have Windows XP SP2 without any updates.
> > 
> 
> Reopening.
> How about Safe Mode?
> 


Safe mode doesn't help for me. :(

Comment 19

13 years ago
Posted image threads list

*** This bug has been marked as a duplicate of 213637 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.