planet.mozilla.org feed creates multiple entries for hixie's blog

RESOLVED DUPLICATE of bug 258465

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 258465
13 years ago
9 years ago

People

(Reporter: Hanspeter Niederstrasser, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Thunderbird 0.9 (20041103)

Using TB 0.9, I've added the planet.mozilla.org RSS feed (see URL) to the News &
Blogs account.  All my other feeds (Fink, Nature, /.) work OK, and p.m.o works
fine _except_ for Hixie's posts.  In these cases, the post first shows up
normally only once, but then after a day or two, the same post reappears next to
the original.  "Small and beautiful" just showed up again today (orig date is
2004-11-19) for the third time.

Reproducible: Always
Steps to Reproduce:
1. Add the p.m.o URL to the feeds for Thunderbird
2. Watch for Hixie's posts to get added more than once
3.

Actual Results:  
Some of Hixie's blog entries get added again after a couple days.  Some twice
(eg. Keeping busy; It's really bad), some 3 (eg. Small and beautiful; Winter). 
The multiple copies don't appear all at the same time, but each new copy comes
around every other day or so.

Expected Results:  
Only one entry for Hixie's thoughts.

I'm posting this under Thunderbird since the feed itself seems to be OK (the
p.m.o website doesn't show the multiple entries, for example).  However, I don't
have another RSS feed program to test it on, so it might actually be an issue
with the RSS feed itself.

I don't think this is Bug 267139 since I'm not deleting any of the messages but
leaving them all in their original feed folder.
(Reporter)

Comment 1

13 years ago
Adding Ian to the CC list since it's his blog where this issue shows up.  Going
to check if I also get the duplicate entries by directly reading Hixie's RSS feed.
(Reporter)

Comment 2

13 years ago
Found dupe.  Seems to be a general issue and not just with Hixie's blog (direct
link to his also caused duplicates, btw).

*** This bug has been marked as a duplicate of 258465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.