bottom of scroll bar is hidden when tab bar shifts page down

RESOLVED DUPLICATE of bug 285445

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 285445
13 years ago
13 years ago

People

(Reporter: Michael Newton, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

With no tabs open, I open a Siebel eService application.  The page uses a
frameset, with the bottom frame having a scroll bar, and all is good.  If I then
open a tab, the bottom frame fails to resize.  The bottom of the scrollbar and
the page content is covered by the status bar.  I will attach screenshots, and
make up a testcase shortly.

This may belong in another component?  I figured this was a failure by the
tabbed browsing component to fire an event.

Reproducible: Always
Steps to Reproduce:
1.open a horizontally framed page with no tab bar showing (bottom frame should
have scrollbars)
2.open a new tab

Actual Results:  
the frame fails to resize, cutting off content

Expected Results:  
the frame should resize to make room for the tab bar
(Reporter)

Comment 1

13 years ago
Created attachment 166971 [details]
The frameset without any other tabs
(Reporter)

Comment 2

13 years ago
Created attachment 166972 [details]
the frameset after a tab has been opened

Note the scrollbar cut off at the bottom; the last line of data is also
obscured.
*** Bug 269597 has been marked as a duplicate of this bug. ***
I couldn't reproduce it with the site mentioned in bug 269597. Couldn't find any
other dupes either.
Severity: normal → trivial
Summary: status bar covers page content during tabbed browsing → bottom arrow of scroll bar is partially hidden when tab bar shifts page down

Comment 5

13 years ago
Are you using Firefox 1.0 on Windows? If so, you'll see it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

13 years ago
Created attachment 166973 [details]
filler for the testcase frameset
(Reporter)

Comment 7

13 years ago
Created attachment 166977 [details]
the testcase

The deciding factor here is the frameborder="no" attribute.  Take that away and
it resizes correctly.
(Reporter)

Updated

13 years ago
Keywords: testcase

Comment 8

13 years ago
i think that something similar happens w/ gmail and the sidebar...
(Reporter)

Comment 9

13 years ago
changing summary to once again include the fact that this affects page content
as well as the entire scroll bar arrow
Summary: bottom arrow of scroll bar is partially hidden when tab bar shifts page down → bottom of scroll bar and page content are hidden when tab bar shifts page down
It hides the page content on purpose, since it needs space to put the tab bar.
It just doesn't resize the scrollbar appropriately.
Summary: bottom of scroll bar and page content are hidden when tab bar shifts page down → bottom of scroll bar is hidden when tab bar shifts page down
*** Bug 276351 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
*** Bug 284936 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 285445 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.