File>Close Window problem

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: macster_smart, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

If I have one Firefox window opened with many tabs opened in that window, every
tab containing a webpage, and wana save every page, if I make a wrong click and
click instead of File>Save Page As to File>Close Window the Firefox Window
closes whithout asking me if I wana close it because it contains many tabs, and
I lose all the opened webpages opened in tabs.


Reproducible: Always
Steps to Reproduce:
1. I lose all the webpages opened in tabs if I click File>Close Window, when I
just wana click File>Save Page As,  the two are close one to another and
missclick occurs so if u make a wrong click you lose all the webpages that you
want to save them instead.

Actual Results:  
I lose all the webpages opened in tabs if I click File>Close Window, when I just
wana click File>Save Page As,  the two are close one to another and missclick
occurs so if u make a wrong click you lose all the webpages that you want to
save them instead.

Expected Results:  
An asking dialog should apear that asks you if you wana close this window
because it contains more tabs.


I have lose many opened webpages that I wana save them instead, because this issue.

Comment 1

14 years ago
That dialog already exists (and it was by default on) ! See Option -> Advanced
-> Tab Browsing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

14 years ago
That dialog shows when you close a window by X button or rightclick on taskbar
then chose Close, but it does not appear when you click on File menu then Close
Window, and that's the problem.
You need to log in before you can comment on or make changes to this bug.