autocomplete entries can't be deleted with shift+delete, must use shift+del

RESOLVED FIXED

Status

()

--
minor
RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: jalemon, Assigned: mano)

Tracking

unspecified
PowerPC
Mac OS X
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

On the Macintosh platform, there are both "delete" and "del" keys. The "delete"
key is far more commonly used, including for deleting files in Finder, et
cetera. To delete an entry from a form entry's autocomplete list, one is
supposed to select the item and press shift+delete. However, on the Mac,
shift+delete does not work for this, and one must use shift+del. The more
Mac-centric shift-delete should be supported.

Reproducible: Always
Steps to Reproduce:
1. Add a couple items to a form entry field.
2. Try to delete one with shift+delete.
3. Try to delete one with shift+del.

Actual Results:  
Nothing happens as a result of step 2. Step 3 succeeds in removing the item from
the autocomplete list.

Expected Results:  
The item should have been removed as a result of step 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: bugs → nobody
Component: Form Manager → Autocomplete
Product: Firefox → Toolkit
QA Contact: firefox.form-manager → nobody
Created attachment 167770 [details] [diff] [review]
patch

on mac, backspace is expected to be another delete key (in any case which is
not text-editing)
Assignee: nobody → bugs.mano
Status: NEW → ASSIGNED
Comment on attachment 167770 [details] [diff] [review]
patch

OK, OK. what are first-review and secod-review. when do i need the second one?
Attachment #167770 - Flags: first-review?(mconnor)
Comment on attachment 167770 [details] [diff] [review]
patch

whoever set up the flags used Calendar as a base.  Meh.  This is enough, silly
Macs.
Attachment #167770 - Flags: first-review?(mconnor) → first-review+

Comment 4

14 years ago
Checking in mozilla/toolkit/content/widgets/autocomplete.xml;
/cvsroot/mozilla/toolkit/content/widgets/autocomplete.xml,v  <--  autocomplete.xml
new revision: 1.34; previous revision: 1.33
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 290917 has been marked as a duplicate of this bug. ***
*** Bug 290917 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
in the meantime, apple laptop users can use fn-shift-delete to emulate
shift-del. i tried this and it works.

Updated

12 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.