download is broken in Mozilla 1.8a5, not starting at all. Exception in JavaScript console

RESOLVED DUPLICATE of bug 256365

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED DUPLICATE of bug 256365
13 years ago
13 years ago

People

(Reporter: Mihail Daskalov, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041122
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041122

The download feature is broken in Mozilla 1.8a5.
I mean no way to download files with Mozilla 1.8a5. Downloads are not starting
at all. In some cases there is Error:Exception in JavaScript console, in some
there is not.

Reproducible: Always
Steps to Reproduce:
1.go to http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.8a5/
2.right-click the mozilla-win32-1.8a5-installer.exe link
3.select 'Save link as'
4. when the dialog box appears select a directory where to save the file and
click OK.
Actual Results:  
Nothing happens, except the Error in Javascript console:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIDownload.init]"  nsresult:
"0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame ::
chrome://communicator/content/contentAreaUtils.js :: internalSave :: line 367" 
data: no]

Expected Results:  
Start downloading the file and show either progress dialog, or download manager.

Actually I couldn't find a way to download any file.
Tests I have tried:
1) Pasting a link to a .ZIP or .XLS file in the URL field results in
'Transferring data...' in the status bar, and nothing happens (no Save As dialog)
2) Left-Click on the link doesn't do anything (no Save As dialog).

All downloads worked fine before I deinstalled Mozilla 1.7.3.
I installed Mozilla 1.8a5 in same directory as Mozilla 1.7.3.
All downloads work fine with Mozilla Firefox 1.0, so this is not a connection issue.

Sometimes I receive a messagebox with title 'Downloading
F:\my_temp_directory\8w3j425q.xls' stating:
'F:\my_temp_directory\8w3j425q.xls could not be saved, because the source file
could not be read.
Try again later, or contact the server administrator.'
(Reporter)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 256365 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.