Closed Bug 271729 Opened 20 years ago Closed 20 years ago

No Automatic Filter For Global Inbox

Categories

(MailNews Core :: Filters, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: afranke, Assigned: Bienvenu)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This feature should really be added.  I find it quite annoying that I have to
manually apply filters every time mail is checked.  Why would you not make that
even an option?

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is currently classed as an enhancement.  Surely this is a defect right?  
There is nothing in the release notes or GUI that indicates this functionality 
is not available.
You set up filters for each incoming pop3 server, not for the local folders
account.  Until 1.0, there was a bug where creating filters would create filters
for the local folders account, when instead, it should create them for the pop3
incoming server.

So yes, this is an enhancement, to have global filters that apply to all
incoming pop3 servers that deliver mail into the global inbox.
(In reply to comment #2)
> So yes, this is an enhancement, to have global filters that apply to all
> incoming pop3 servers that deliver mail into the global inbox.

Well, this should be done automaticly. It is not an enchnchancement - is a
misleading thread to a user... IMO a poor interface design.
To me, it's a show stopper, as I'm getting totally sick of having to run the
filters manually each time I get new mail, and attempting to set the filters for
each POP3 account, as David Bienvenu suggests does not work, I can either have
no filters on the POP3 account, or filters on the Global Inbox that work, but do
not get actioned when new mail arrives.
setting filters on pop3 accounts with the global inbox works fine for me, and I
haven't heard any other reports that it doesn't work...are you saying that
having filters on the pop3 accounts breaks running filters after the fact?
Attempting to set filters on POP3 accounts is totally broken here, I am them
through the UI, and they disappear next time TB is restarted.  I wonder if it's
because I only have a single POP3 account (I use Global Inbox only to get rid of
the seperate POP3 and Local Folders).
Adam Franke(reporter of this bug), Mark Gillespie and Kamil Dzielinski, if you
say "I have to run manually", read next Thunderbird FAQ first(especially
"Important:" part), please. 
http://kb.mozillazine.org/index.phtml?title=Thunderbird_:_FAQs_:_Filters

Then read comment #2 and comment #4 by David Bienvenu again.

Then analyze your problem, and try to find what is flaw, or try to discuss on 
enhancement to resolve your problem.

By the way, please note that bugzilla is not for saying complaints nor Q&A.
Bugzilla is for analysis of problem/finding flaw/finding solution, and
discussion on enhancement/finding best solution for the enhancement.
OK, will try to explain the problems I am seeing here with 1.0 release of TB on
Win32 platform.

My setup:  Using Global Inbox, with a single POP3 account (using global inbox to
get rid of the Local Folders AND the account folder, as I only want 1 inbox).

Problem 1 - Filters do not run automatically (this is the documented
shortcomming of Global Inboxes)
Steps to reproduce:

1/ Create message filters for local folders, when mail arrives, the do not get
run automatically.  Tools, Run Filters On Folder DOES work however, indicating
the filters work, just not the triggering.

Problem 2 - The famous disappearing filter trick
Steps TO Reproduce:

1/  Higlight the Inbox (the only inbox)
2/ Select Manage Message Filters (from the R/H pane)
3/ Filters are shown for Local Folders
4/ Click "Filters For" and select POP3 account, no filters are shown
5/ Click "Filters For"  and go back to the Local Folders. - No filters are shown
6/ Does not matter what "Filters For" is now selected, filters are never displayed

NOTE:  The only thing I have changed from default, is the naming of Local
Folders, I have renamed mine to Email (this may or may not make a difference to
this)

Problem 3 - Filters cannot be set on individual POP3 accounts when using global
inbox
Steps TO Reproduce:

1/  Higlight the Inbox (the only inbox)
2/ Select Manage Message Filters (from the R/H pane)
3/ Filters are shown for Local Folders
4/ Click "Filters For" and select POP3 account, no filters are shown
5/ Add a new filter using New button, enter some filter details (does not matter
what)
6/ Filter is then shown.
7/ Click "Filters For" and select local folders, filter is still shown!!!
8/ Click "Filter For" and select News And Bloggs, filter is still shown!!!
9/ Close Thunderbird and reopen, reopen Manage Message Filter.
10/ Select "Filter For" and select POP3 account, filter is NOT shown.

Hope this helps, I know it's several problems here, and it may be that we need
to create several bugzilla entries for all these, but I am trying to show that
there is NO current workaround for having filters run automatically when using
Global Inbox, because setting the filters on the POP3 account simply does not
work (they disappear when TB is restarted).
(In reply to comment #8)

> Problem 2 - The famous disappearing filter trick

> NOTE:  The only thing I have changed from default, is the naming of Local
> Folders, I have renamed mine to Email (this may or may not make a difference to
> this)

(Q1) What did you rename to "Email"? How did you rename?(TB's UI,Text editor,...)
   (a) Renamed account name from "Local Folders" to "Email"
   (b) Renamed directry of "Local Folders" under mail directry to "Email"
   (c) Renamed other to "Email" ( Q1-2 : What is other? How? )

(Q2) When did you rename something to "Email"?
     ( Between which steps in "Step to reproduce" )
     (  of your Problem 1/Problem 2/Problem 3?    )

> Problem 3 - Filters cannot be set on individual POP3 accounts when using global
inbox

(Q3) Is this when default status? Or after you renamed something to "Email"?
 
> Problem 1 - Filters do not run automatically (this is the documented
> shortcomming of Global Inboxes)

(Q4) Is this when default status? Or after you renamed something to "Email"?

Anyway, Mark Gillespie, see your prefs.js, then think about what "naming" means
and what will happen if name of something is changed, please.
Had some time to look at this today.  Created a new profile, and guess what. 
Everything works as expected, I can create a filter on the POP3 inbox (using
same method as before), I even renamed my profiles as I did with my other profile!!

Even the "Get Mail" button has started working...!!!

Seems my profile is somehow screwed. (it a profile I have been using since about
TB 0.3)

I would rather not post my prefs.js here, but if any of the developers want a
copy of it, to reproduce the problems I have been describing, please email me.

Of course this "No Automatic Filter For Global Inbox" defect still stands, but I
now have a working workaround.

sure, Mark, send me your prefs.js and I'll look at it.
(In reply to comment #10)
> Created a new profile, and guess what. Everything works as expected
Congraturations!
I guess your answer to my (Q1) is (b). Mark, isn't it right? ;-)
yes, I renamed Local Folders using UI, Q1-(b)
Anybody know *WHY* filters for Local Folders are not applied automatically?
Attached patch proposed fixSplinter Review
this patch makes it so if you get mail in a deferred account, we'll run both
the filters for the deferred account and the deferred to account. So in the
global inbox case, we'll run filters for the pop3 server/account, and then the
local folders filters.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → ASSIGNED
Attachment #176948 - Flags: superreview?(mscott)
Attachment #176948 - Flags: superreview?(mscott) → superreview+
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Component: Preferences → MailNews: Filters
OS: MacOS X → All
Product: Thunderbird → Core
Hardware: Macintosh → All
Version: unspecified → Trunk
*** Bug 289680 has been marked as a duplicate of this bug. ***
Cool. A code-level change. Too bad I'm not a coder <_<. Will this appear in a
future version of Thunderbird? If so, what version?

A few tips on UI design:

"If there's a 'trick' to it, the UI is broken." --Douglas Anderson

"It is a far better to adapt the technology to the user than to force the user
to adapt to the technology." --Larry Marine

Both quotes taken from "Software Engineering: A Practitioner's Approach" by
Roger S. Pressman, Ph.D. - who himself has this tip: "Define interaction modes
in a way that does not force a user into unnecessary or undesired actions" (page
326).
the fix will be in 1.1 - I can't tell if you're being ironic or not, but once
you get 1.1, you won't have to do anything special - both sets of filters will
run, for the default case, so it will be hard for the user to mess up :-)
Thanks.

I should clarify: I am a programmer in that I have the skills, but I do not have
the tools or source code neccessary to compile Thunderbird on my computer.
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: