If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsPrintDialogUtil.cpp uses a localizable string for a preference

RESOLVED FIXED in mozilla1.8beta3

Status

()

Core
Printing: Output
P1
normal
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: mconnor, Assigned: Benjamin Smedberg)

Tracking

Trunk
mozilla1.8beta3
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8b5 +
blocking-aviary1.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Spun off from bug 271470

http://lxr.mozilla.org/mozilla/source/embedding/tests/mfcembed/components/nsPrintDialogUtil.cpp#903
http://lxr.mozilla.org/mozilla/source/embedding/components/printingui/src/win/nsPrintDialogUtil.cpp#914

bug 78319 comment 80 seems to indicate this was done for a fallback, but I don't
think there's any current need for a fallback, especially as I think all Firefox
translations seem to be fine with using the extended dialog.

We should probably just trash this code and always use the extended dialog, or
convert this to a pref-based item so that we can disable the frames thing
per-app instead of per-language (i.e. Thunderbird probably doesn't need UI for
printing frames, nor would a random embedding app).
This should block aviary 1.1 to reduce the number of localization train wrecks.
Flags: blocking-aviary1.1+
Created attachment 175529 [details] [diff] [review]
untested patch

This is completely untested; I don't have a Windows build environment.	If
someone could make it compile and test it, that would be great!
Comment on attachment 175529 [details] [diff] [review]
untested patch

Since you seem (per comments on bug 271470) to prefer this approach, any chance
you could test and review this?
Attachment #175529 - Flags: review?(benjamin)
Assignee: printing → dbaron
Whiteboard: [patch]
Target Milestone: --- → mozilla1.8beta3
(Assignee)

Comment 4

13 years ago
*** Bug 271470 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Blocks: 286312
(Assignee)

Updated

13 years ago
Assignee: dbaron → benjamin
Flags: blocking1.8b4+
Priority: -- → P1
(Assignee)

Comment 5

13 years ago
Comment on attachment 175529 [details] [diff] [review]
untested patch

WFM.
Attachment #175529 - Flags: review?(benjamin)
Attachment #175529 - Flags: review+
Attachment #175529 - Flags: approval1.8b3?
so why not just always show the dialog?
(Assignee)

Comment 7

13 years ago
I don't know, but there might be a reason having to do with localized Windows?

Updated

13 years ago
Attachment #175529 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 8

13 years ago
Fixed on trunk for 1.8b3
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
The "extend=true" string in printdialog.properties is still there. Was that part
of the patch not checked in?

Comment 10

13 years ago
(In reply to comment #9)
> The "extend=true" string in printdialog.properties is still there. Was that part
> of the patch not checked in?

Looks like that:
http://lxr.mozilla.org/seamonkey/source/dom/locales/en-US/chrome/printdialog.properties#45

Comment 11

13 years ago
 
> Looks like that:
>
http://lxr.mozilla.org/seamonkey/source/dom/locales/en-US/chrome/printdialog.properties#45

Err, I meant that it was never checked in for some reason...
I checked in the missed change on the trunk.  Not sure whether we want it on the
branch at this point as well.
(Assignee)

Comment 13

12 years ago
Let's leave it on the branch, it's not going to hurt anyone no matter how it's
translated.
You need to log in before you can comment on or make changes to this bug.