GTK native filepicker is not modal

RESOLVED DUPLICATE of bug 301004

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 301004
13 years ago
13 years ago

People

(Reporter: RamaSubbu SK, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

I have enabled GTK fileselector for Firefox, it is working fine. But that file
selectot is not a modal window. Once the file selector is opened, you can still
go back to the browser and do the file->exit. Firefox window quits, but the GTK
fileselector remains open. 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Reproducable. Confirming the bug. Changing the state to Minor.
Severity: major → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: firefox → bugs
Component: Menus → OS Integration
QA Contact: bugzilla → firefox.os-integration

Updated

13 years ago
Summary: GTK fileselector is not modal window. → GTK filepicker is not modal

Updated

13 years ago
Summary: GTK filepicker is not modal → GTK native filepicker is not modal
Yeah, I know.  For some reason, the GtkWidget we're getting using is not the
toplevel.  Not sure why since it appears we're walking up the right chain of
command.
Assignee: bugs → caillon
Patch in hand on bug 301004

*** This bug has been marked as a duplicate of 301004 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.