Show full newsgroup name as tooltip for abbreviated newsgroup names

RESOLVED FIXED in Thunderbird 3.0b3

Status

--
enhancement
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: OlafvdSpek, Assigned: mkmelin)

Tracking

Trunk
Thunderbird 3.0b3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the tree pane, newsgroup names are shown as l.d.user (for example) and
there's no tooltip. It'd be nice if the tooltip would show linux.debian.user
instead.

Reproducible: Always
Steps to Reproduce:
1. -
2.
3.

Comment 1

14 years ago
This is the Moz Suite Mailnews bug 174234.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

14 years ago
Incidentally, this would be better handled as a "title tip" -- that is, one that 
overlays the text being expanded, rather than appearing offset.  See bug 75698.
(Assignee)

Comment 3

13 years ago
*** Bug 342115 has been marked as a duplicate of this bug. ***
QA Contact: front-end
Assignee: mscott → nobody
(Assignee)

Comment 4

10 years ago
Created attachment 381349 [details] [diff] [review]
proposed fix

Adds the full newsgroup name as a tooltip if the abbreviated version is used.
Fixed the flags and wrapped a few overlong line while i was there.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #381349 - Flags: ui-review?(clarkbw)
Attachment #381349 - Flags: review?(jminta)
(Assignee)

Updated

10 years ago
Target Milestone: --- → Thunderbird 3.0b3
Attachment #381349 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 381349 [details] [diff] [review]
proposed fix

sounds good!
(Assignee)

Comment 6

9 years ago
Joey?
(Assignee)

Updated

9 years ago
Attachment #381349 - Flags: review?(jminta) → review?(bienvenu)

Comment 7

9 years ago
Comment on attachment 381349 [details] [diff] [review]
proposed fix

looks good, thx!
Attachment #381349 - Flags: review?(bienvenu) → review+
(Assignee)

Comment 8

9 years ago
changeset:   3016:8d4cc7578a37
http://hg.mozilla.org/comm-central/rev/8d4cc7578a37

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: Long tooltips for newsgroup names → Show full newsgroup name as tooltip for abbreviated newsgroup names
Created attachment 400314 [details] [diff] [review]
(Bv1) Fix nits to sync with SeaMonkey
[Checkin: Comment 11]
Attachment #400314 - Flags: review?(bienvenu)
Version: unspecified → Trunk
Comment on attachment 400314 [details] [diff] [review]
(Bv1) Fix nits to sync with SeaMonkey
[Checkin: Comment 11]

r=Standard8
Attachment #400314 - Flags: review?(bienvenu) → review+
Comment on attachment 400314 [details] [diff] [review]
(Bv1) Fix nits to sync with SeaMonkey
[Checkin: Comment 11]


http://hg.mozilla.org/comm-central/rev/8c33e59f55dc
Attachment #400314 - Attachment description: (Bv1) Fix nits to sync with SeaMonkey → (Bv1) Fix nits to sync with SeaMonkey [Checkin: Comment 11]
You need to log in before you can comment on or make changes to this bug.