[patch] Fix mac about box

VERIFIED FIXED in Thunderbird1.0

Status

VERIFIED FIXED
14 years ago
13 years ago

People

(Reporter: mano, Assigned: mano)

Tracking

unspecified
Thunderbird1.0
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(This is the tb version of bug 222364, and maybe a dupe...)

The about box shoudn't be a sheet (or even app-modal/doc-modal) on mac, and
shoudn't have a close button.
Created attachment 167111 [details] [diff] [review]
patch

[mac only of course] this:
1. removes modal window feature on mac.
2. Uses window.open instead of window.openDialog to avoid missing
close-window-button.
3. places the extra2 button at the right side (or left in a RTL gui)
Assignee: mscott → bugs.mano
Status: NEW → ASSIGNED
Scott, I know i'm pretty late in this game, but this one is pretty safe.
Flags: blocking-aviary1.0?
Target Milestone: --- → Thunderbird1.0

Updated

14 years ago
Attachment #167111 - Flags: review?(mscott) → review+

Comment 3

14 years ago
cool I'll check this into the 1.0 branch. It's pretty low risk.

thanks for taking care of this. 

Comment 4

14 years ago
do we need to fix up the about callers for mail compose and the address book too? 
Flags: blocking-aviary1.0?

Comment 5

14 years ago
this patch is checked in the branch and the trunk. Leaving open for Asaf to tell
us if we need  to do anything for compose and address book...I suspect we do. 
Created attachment 167138 [details] [diff] [review]
err, my bad

Sorry for spamming epository earlier... So this one moves openAboutDialog to
mailCore.js and fixes addressbook & compose clients.

Updated

14 years ago
Attachment #167138 - Flags: review?(mscott)

Comment 7

14 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
vrfy'd fixed with 2004120102-0.9 on mac os x 10.3.6.

sidenote: the version string seems to be selected (highlighted) when bringing up
the about window.
Status: RESOLVED → VERIFIED

Comment 9

14 years ago
*** Bug 272911 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
the address book change never got checked in in the second patch for this bug. I just fixed that on the trunk. 
*Ugh*, do we happen to have more 1.5 respins?

Comment 12

13 years ago
i checked in the addressbook change onto the 1.8.1 branch so it will be fixed in thunderbird 2.0.
Depends on: 320880
You need to log in before you can comment on or make changes to this bug.