form includes all the content below it if it contains an unclosed </p> paragraph

RESOLVED DUPLICATE of bug 22480

Status

()

RESOLVED DUPLICATE of bug 22480
14 years ago
13 years ago

People

(Reporter: mike.hall, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: see comment 7)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0

The end of the page does not print. 
Print css has form {display: none}
Nothing beyond the two <form...>...</form> tags shows in print preview or prints.
Works correctly in IE and Opera, has same problem in Netscape 7.1.
Have checked that html and both css sheets validate correctly.

Reproducible: Always
Steps to Reproduce:
1. enter the url
2. do File > Print preview and note that end of the page has gone


Actual Results:  
shows incorrect printing

Expected Results:  
The forms should not print, but everything following, from    Copyright...
should be printed

Comment 1

14 years ago
Could you try to get your testcase down to the smallest size possible? And retry
with the latest nightly trunk available here:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk
(Reporter)

Comment 2

14 years ago
(In reply to comment #0)
Can't test with the latest nightly trunk - it gives XML error on my system
(Firefox won't start) - have had to reinstall normal version.
Minimum test case is at http://onepoyle.net/art/firefox_print_after_form.html
The <p> tag within the <form... is necessary for the error to appear - without
that line it works OK.
Have now found that the error can be fixed by closing the para within the form
with </p> - have fixed the original perl script so it now does that - leaving
upload until later to avoid confusion. The minimum test case at
http://www.onepoyle.net/art/firefox_print_after_form.html will remain...
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5)
Gecko/20041110 Firefox/1.0
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5)
Gecko/20041110 Firefox/1.0
> 
> The end of the page does not print. 
> Print css has form {display: none}
> Nothing beyond the two <form...>...</form> tags shows in print preview or prints.
> Works correctly in IE and Opera, has same problem in Netscape 7.1.
> Have checked that html and both css sheets validate correctly.
> 
> Reproducible: Always
> Steps to Reproduce:
> 1. enter the url
> 2. do File > Print preview and note that end of the page has gone
> 
> 
> Actual Results:  
> shows incorrect printing
> 
> Expected Results:  
> The forms should not print, but everything following, from    Copyright...
> should be printed


Comment 3

14 years ago
I'm still not sure on your testcase. As far as I can see now it has to do with
the paragraph tags not closed. Which is correct HTML but causing trouble.

Could you try to make your testcase attached to this bug in bugzilla. With the
CSS inside the file and not seperated. And both as limited as possible.
(Reporter)

Comment 4

14 years ago
Created attachment 167202 [details]
html page demonstrating bug
(Reporter)

Comment 5

14 years ago
The form includes a paragraph not terminated by </p>
The form is declared {display: none} for media print.
Text following the form is not printed.

html example now attached with inline css - thanks for your patience, this is
the first bug I have reported - still getting used to the system.
Possibly related to bug 226486.

Comment 7

14 years ago
Created attachment 168539 [details]
testcase: form includes all the content below it

This is not a problem with printing. The form eats up everything below it. The
green border should only be around the first paragraph. But it's around
everything below the </form> tag.
Attachment #167202 - Attachment is obsolete: true

Comment 8

14 years ago
-> Core, Parser.
Assignee: bugs → parser
Component: Product Site → HTML: Parser
Keywords: testcase
OS: Windows XP → All
Product: Firefox → Core
QA Contact: mrbkap
Summary: printing is not correct → form includes all the content below it if it contains an unclosed </p> paragraph
Version: unspecified → Trunk

Updated

14 years ago
Whiteboard: see comment 7

*** This bug has been marked as a duplicate of 22480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.