scope while compiling different js files in the same object

VERIFIED DUPLICATE of bug 26060

Status

()

Core
JavaScript Engine
P3
major
VERIFIED DUPLICATE of bug 26060
19 years ago
17 years ago

People

(Reporter: Dudu Buch, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Hi,

I have cx+obj as prototype("father") for diffrent cx+obj ("son").  When I 
compile a script in the "father" obj it is recognized in the other couple and 
everythign is working fine. Also when I define a property in the son the 
property is recorgnized within a function. 
Then, I compile another script, which contains functions, in the father.
The I call JS_ExecuteScript for first script in using the son cx+obj. The 
functions in the second script are recognized in the son, but properties 
defined in the son before calling the functions are not recognized within the 
functions. (It does not matter if the properties defined usgin 
JS_DefineProperty or just as a variables in the script). When the functions 
where written in the first script (the script which was executed) everything 
worked just fine.  Also when I compile the second script twice inthe father and 
in the son, everything worked just fine. 

I'm using JS 1.5.

Thanks,

dudu.

Comment 1

19 years ago
Roger, could you review this?
Assignee: mccabe → rogerl
(Assignee)

Comment 2

19 years ago

*** This bug has been marked as a duplicate of 26060 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.