JavaScript navigator.appName is "Netscape", why not "Firefox"?

RESOLVED DUPLICATE of bug 61071

Status

()

RESOLVED DUPLICATE of bug 61071
14 years ago
14 years ago

People

(Reporter: u167265, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In JavaScript, the navigator.appName is "Netscape". I've never installed
Netscape on my computer. Why isn't the appName "Firefox"?

Reproducible: Always
Steps to Reproduce:
Put this code in a HTML-page and open it with Firefox:

<script type='text/javascript'><!--

document.write(navigator.appName);

//--></script>
Actual Results:  
"Netscape" was displayed.

Expected Results:  
"Firefox" should be displayed.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 61071 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.