If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

scrolling window is slow and expensive

RESOLVED FIXED

Status

()

Core
Layout: View Rendering
--
major
RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: John M, Unassigned)

Tracking

({perf, testcase})

Trunk
x86
Linux
perf, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041121
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041121

When you scroll the page it is very slow and uses a lot of CPU. Also some of the
content seems to scroll after the page does. For example the list of top rated
games near the bottom of the page scrolls exhibits this behaviour.

Reproducible: Always
Steps to Reproduce:
1.go to the site
2.scroll

Actual Results:  
window scrolls slow and some content scrolls seperately

Expected Results:  
window scrolls like any other website

Comment 1

13 years ago
Created attachment 167321 [details]
testcase

this seems to be a result of a fixed background and overflow: auto

scrolling this testcase is painful with linux trunk build 2004112705 (gtk1) and
also trunk CVS gtk2/xft builds.  The screen actually flickers if I scroll fast
and doesn't look good even if I scroll slowly.

Comment 2

13 years ago
==> gtk
Assignee: general → blizzard
Blocks: 90198
Status: UNCONFIRMED → NEW
Component: General → GFX: Gtk
Ever confirmed: true
Keywords: perf, testcase
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Reporter)

Comment 3

13 years ago
This isn't Linux specific. It happens in Windows to!

Comment 4

13 years ago
John: the gamespot URL is pretty complex.  Does the attached testcase behave the
same under windows and linux?  If not, then you'll need to file a new bug for
the windows perf problem.  If the behavior on windows is similar, then I guess
this is a layout (views?) problem.

See also bug 90198 which is an ambiguous collection of perf problems people see
with fixed background.
See comment 12 in bug 266582.  Since each overflow:auto thing has its own
scrollwidget, we paint the page N times (N == number of overflow:auto things) on
each scroll.

Robert, do we have an existing bug on painting once and then updating all
widgets?  If so, this should depend on it...
No, we don't have such a bug.
Depends on: 274144
OK, I filed bug 274144

Comment 8

13 years ago
I only started slow scrolling on Gamespot after bug 238493 (widget cache)
landed, I think.  On older builds of Firefox, where the Gamespot page would
flicker while loading, the scrolling performance seems to be better to me.

Comment 9

13 years ago
I'd like to nominate this for blocking Firefox 1.1.  Can I just set the flag, or
does someone else need to do it?  I don't want to overstep my authority here.
Nominate it with the "?" flag. You're overstepping your bounds by giving it the
"+" flag.

Updated

13 years ago
Flags: blocking-aviary1.1?

Updated

12 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Testcase still flickers in Firefox trunk Linux.
Assignee: blizzard → roc
Component: GFX: Gtk → Layout: View Rendering
QA Contact: ian → layout.view-rendering
Assignee: roc → nobody
I can no longer reproduce the slow scrolling effects with the latest hourlies. Can anyone on Mac or Linux still reproduce this? If so then please re-open this bug.

Otherwise... -> Fixed by bug 564991.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.