JS error while opening Help Viewer

RESOLVED WORKSFORME

Status

--
trivial
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: stefanh, Assigned: neil)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Mozilla 2004112304 Mac OS 10.3.6

Every time I open the Help Viewer I get a JS error in the console:

"Error: redeclaration of const MOZILLA_CONTENT_PACK
Source File: chrome://help/content/contextHelp.js
Line: 40"
(Reporter)

Comment 1

14 years ago
Hmm... it appears that changing profile makes the error disappear.
(Assignee)

Comment 2

14 years ago
This error can only be caused by including contextHelp.js, either directly or
via helpMenuOverlay.xul; if the window with the problem has a JS console
menuitem you can evaluate top.opener.document.getElementsByAttribute("src",
"chrome://help/content/contextHelp.js").length (which should be 1).

Actually finding the rogue script inclusion is of course much harder :-(
(Reporter)

Comment 3

14 years ago
I haven't seen the js error for some time now, so I'm marking this wfm.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.