bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Status

()

Core
SVG
--
critical
RESOLVED DUPLICATE of bug 269881
14 years ago
14 years ago

People

(Reporter: jonathan chetwynd, Unassigned)

Tracking

({stackwanted})

Trunk
x86
Windows 98
stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041125
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041125

application crashes in win'98, most recent version in osX also crash, as does
firefoxSVG

Reproducible: Always
Steps to Reproduce:
1.open the attachment
2 [review].
3.

Actual Results:  
application crashes


It should be possible to find the systemLanguage via script. this example does
not use systemLanguage as the crash seems to prevent this discovery.
This crash occured during my attempts to understand the current DOM implementation.
It would be useful if nodeValue returned the result of the systemLanguage switch.

This would need to be standards based.Please advise me if this approach is not
appropriate, and will not be implemented.

I wish to understand how one is meant to find the value displayed by the result
of systemlanguage switch using script.
(Reporter)

Comment 1

14 years ago
Created attachment 167211 [details]
crash test: switch
(Reporter)

Comment 2

14 years ago
in some instances it is necessary to refresh to crash application

thisText=myText.firstChild.nextSibling is sufficient to cause a crash [object
SVGSwitchElement] (asv3).

thisText=myText.firstChild.nextSibling.firstChild.nextSibling.firstChild.nodeValue
asv3 returns the first text.nodeValue but doesn't evaluate the switch

Updated

14 years ago
Keywords: stackwanted
This causes an error on loading, but doesn't crash for me. Strange that XTF is
turning up in this error?

WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file
c:/mozilla/trees/trunk/mozilla/parser/htmlparser/src/nsExpatDriver.cpp, line 643
WARNING: no context in AxisLength(), file
c:/mozilla/trees/trunk/mozilla/content/svg/content/src/nsSVGLength.cpp, line 526
WARNING: no context in AxisLength(), file
c:/mozilla/trees/trunk/mozilla/content/svg/content/src/nsSVGLength.cpp, line 526
Testing for XTF factory at
@mozilla.org/xtf/element-factory;1?namespace=http://www.mozilla.org/newlayout/xml/parsererror.xml
Testing for XTF factory at
@mozilla.org/xtf/element-factory;1?namespace=http://www.mozilla.org/newlayout/xml/parsererror.xml
Error loading URL
https://bugzilla.mozilla.org/attachment.cgi?id=167211&action=view : 804b0002

The reason this isn't working is that you forgot the "/" in the closing
</switch> tag. Note, if you wanted to see "splat" in the alert, you should have

thisText=myText.firstChild.nextSibling.firstChild.nextSibling.firstChild.nodeValue

not that that matters for this bug.
Created attachment 167329 [details]
valid test file

Jonathan, can you try with this new attachment where I've corrected the closing
'switch' tag, please. If you don't crash using this, then the SVG component is
probably not the right place for this bug. We'll probably need that stack trace
to determine the correct one.
(Reporter)

Comment 5

14 years ago
Jonathan,

that's most odd, I added various comments over the weekend, duplicating much of
what you've written. However bugzilla seems to have 'lost' them :-(

in particular I commented that this bug specifically relates to the missing
backslash.

Please can you specify what OS you are using, as my application crashes without
fail every time.

I'll need instructions on making a stack trace, the nightly builds I have dont
appear to offer talkback
I'm using Win2k.

You won't really be able to obtain a stack trace unless you are able to build
mozilla. The nightlies can't have talkback because they aren't official builds.
See stack and comments in bug 269881

*** This bug has been marked as a duplicate of 269881 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.