Reloading twice in rapid succession (using F5 or Ctrl+R) should act like "Reload" then "Home" (take user to top of page)

RESOLVED WONTFIX

Status

()

Firefox
General
--
enhancement
RESOLVED WONTFIX
13 years ago
11 years ago

People

(Reporter: stevee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In IE pressing f5 f5 (ie: f5 twice) reloads the page and moves focus to the top
of the page. In FireFox, f5 f5 reloads the page, but focus remains at the scroll
bar position that was present when f5 was pressed.

Reproducible: Always
Steps to Reproduce:
1. Scroll to the bottom of this page
2. Hit f5 f5 (ie: f5 twice in quick succession)

Actual Results:  
Firefox refreshes the page, and moves focus to the bottom of the page (where it
was when f5 f5 was pressed)

Expected Results:  
Firefox should refresh the page, and move focus to the top of the page (as in
the vertical scrollbar should be at the top)

This is how IE works. It would be nice if this was also how Firefox works.
*** Bug 272027 has been marked as a duplicate of this bug. ***
I'm not even sure that it is a feature in IE, rather than a bug. What is this
used for? How is it beneficial? Either way, it's an RFE, and not a bug. Very
likely to   be WONTFIXED as I can't see how it enhances anything.
Severity: minor → enhancement
Summary: f5 f5 should reload the page AND take user to top of page → Reloading twice in rapid succession (using F5 or Ctrl+R) should act like "Reload" then "Home" (take user to top of page)
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> I'm not even sure that it is a feature in IE, rather than a bug. What is this
> used for? How is it beneficial? Either way, it's an RFE, and not a bug. Very
> likely to   be WONTFIXED as I can't see how it enhances anything.

It's not a bug of IE, it's a feature. Anyone who uses the kb to navigate the web
uses it frequently, especially on forums where refreshing and moving to the top
of the page is the most efficient way of reading said forum.

It's an enhancement because many users coming from IE expect such behaviour, and
adding such behaviour to firefox won't break or complicate anything; it will
only make firefox that little bit better, and everything counts right?

by all means mark as WONTFIX, but adding this functionality can only be a good
thing.
(In reply to comment #3)
> It's not a bug of IE, it's a feature. Anyone who uses the kb to navigate the web
> uses it frequently, especially on forums where refreshing and moving to the top
> of the page is the most efficient way of reading said forum.

Can you not use the Home key to do just that? I don't know whether it's
necessary to add some obscure feature that I've never heard of when there's
already a key that does it just perfectly. This just doesn't seem very intuitive
to me.

> It's an enhancement because many users coming from IE expect such behaviour, and
> adding such behaviour to firefox won't break or complicate anything; it will
> only make firefox that little bit better, and everything counts right?

Actually, it will complicate things. When users reload twice and see unexpected
behavior they've never seen before, they're going to think that it's a bug and
file it.
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
The blocking flag is for bugs that might actually block a release. An
unconfirmed request for an enhancement with dubious value is *not* going to
block a release.
Flags: blocking-aviary1.1?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Steve, can you resolve this by setting a new or whatever ?
Note that it's not necessary to confirm bugs, simply commenting is enough to
keep them from being auto-resolved.
Assignee: bross2 → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.