Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 36810
13 years ago
13 years ago

People

(Reporter: mike lima, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

My suggestion is the following: one of the most annoying things when Mozilla
crashes, and it crashes several times (many of these problems related to Flash,
Java and other plugins), is that you lose the pages you were on, the tabs that
where opened, etc.

I suggest a way to keep track automatically of what windows and tabs are opened
and which pages are being saw on that windows/tabs, all transparent, without
user intervention, so, when the user runs mozilla again after a crash, a window
would pop up and offer an option called RESTORE PREVIOUS PAGES BEING SAW BEFORE
CRASH.

Another usefull thing is that this function can also be offered as an option for
what to do when mozilla starts, i.e., an user can choose to always restore last
opened pages when running mozilla.



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Bugzilla (the product you filed this bug against) isn't a browser, it's a bug
tracker. :)  You used Firefox to file this bug, but you state "Mozilla" in your
description.  I'm going to go with your description and assume you mean the
Mozilla Application Suite, and move this bug there.
Assignee: myk → general
Component: User Interface → General
Product: Bugzilla → Mozilla Application Suite
QA Contact: mattyt-bugzilla → general
(Reporter)

Comment 2

13 years ago
oh, sorry for that. thanks!

Comment 3

13 years ago
To the crashing: Try to keep your plugins up-to-date, for example a big crasher
was fixed in Java 1.5.0

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

13 years ago
Yes they are. I have the latest version of all of them. Anyway, this is a
suggestion for a function...:-)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.