Table cell proportions not invariant under redrawing when css width expressed as %ge.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Goetz Heller, Unassigned)

Tracking

({css1, js1.5})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

In the page http://www.seidenweich.de/sw_streetshops.php?id=4, a two-column 
table has a total width of 96%, the first column 30%, the second 70%. Depending
on the selection made in a select element inside the left column, a particular
div out of several ones is displayed inside the second column (display:block;)
while rendering of the others is suppressed (display:none;). Each time a
selection is done, the left column shrinks a little bit until this is stopped by
the length of a single text word contained in the first column to avoid breaking
up the word into two parts - the line consisting of several words starts being
wrapped at some point. Correct behaviour would leave the column proportions
invariant as is the case with IE 6.0.

Reproducible: Always
Steps to Reproduce:
Obvious from details.

Actual Results:  
column proportions changed

Expected Results:  
leave the column proportions invariant

There appears to be a relationship to bug 210657, incorrect scroll behaviour of
div areas when the css width is given a percentage value. After all that time -
more than a year - I consider this a serious bug since such things steal very
much time from web page designers and developpers. I appreciate all the work end
effort spent for the community. However, bugs surviving such a long time and so
many versions of gecko have some impact on the credibility of the idea of open
source software. It is really time for a set of correct, stable, and consistent
algorithms making the effects of recalculating positions and sizes of page
elements reliable and predictible.

Comment 1

13 years ago
I have also encountered this issue. I have a table with two columns where the
data within the second column is updated depending on the state of the first
column. When the table width is set using a relative value and the cells are
also set using relative values the second columns width increases each time it's
data is refreshed. The problem seems to be caused by the value of offsetWidth
increasing when it should remain constant. This is not an issue in IE. It is an
issue in Firefox 1.0 and Mozilla 1.7. It appears to be fixed in Mozilla 1.8a5.
Can anyone tell me what version of Firefox will contain this fix? This bug is
causing problems with attempting to acheive cross browser compatability for our
product. The workaround of having the table width set to a fixed number of
pixels is not optimal.

Comment 2

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050901
Firefox/1.0+ ID:2005090106

I can't confirm this bug with the above nightly.  Does this behavior persist in
the current build?
Keywords: css1, js1.5

Comment 3

12 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050901
Firefox/1.0+
Assignee: bross2 → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.