Mozilla keeps crashing with certain HTML-pages/contents

RESOLVED DUPLICATE of bug 19454

Status

defect
RESOLVED DUPLICATE of bug 19454
15 years ago
15 years ago

People

(Reporter: WISD00M, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

Hi ! 
 
I've noticed that there are still problems with some webpages/contents -  
often times Mozilla simply quits, closing all its tabs and windows, however 
what's really annoying is that Mozilla isn't able to restore the original 
session(s) (tabs & windows) after restarting. 
 
I assume that this is because the session information isn't flushed during 
such a crash, that's why I'd like to make the following suggestions: 
 
(Optionally) put the retrieving, parsing and rendering routines into 
try { } catch() statements - so that whenever an error is encountered, 
Mozilla can at least save the latest session information - maybe only  
for developer/debug versions ? 
 
A simple workaround would be to write session information prior to each 
retrieving, personally I wouldn't mind the potential performance overhead 
if that guarantees that I can restore my session later, but others might 
object ...  
 
Alternatively, make this an option within the preferences for every user. 
 
That way mozilla would be able to permanently update/maintain some kind 
of "worst case" scenario "pre-crash" file with the most recent information. 
 
In order to allow you guys tracking down the nature of the problem, I 
think that it might be useful to allow users to optionally enable 
some sort of "session monitoring", that might comprise logging  
actions and events, such as "resolve DNS", "get page", "parse file", 
"parse tag", "render image" etc. 
 
Additionally, such a status file could also contain other useful 
information - for example the plain text contents of the HTML file  
that was retrieved. 
 
So Mozilla could by default write all such information to a temporary file 
within 
$HOME/.mozilla/action-status.xml that might keep the last x actions (FIFO) so 
that  
the file can be used for debugging purposes whenever there's really a problem: 
as 
long as there's no problem, the file keeps getting overwritten. 
 
But as soon as an exception is caught, mozilla could offer during restart to 
display 
the stored information and optionally transfer this to bugZilla. 
 
Also, in general it would be nice if there was an option to tell mozilla to 
use 
more than one process, so that only the process of the actual window/tab is 
affected 
and not all other tabs & windows, too. 
 
 
 
Thanks for such a great browser !  
 
 
regards 
 
 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

*** This bug has been marked as a duplicate of 19454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.