Wrong reply address created from sender address with umlaut

RESOLVED DUPLICATE of bug 254519

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 254519
14 years ago
14 years ago

People

(Reporter: Thomas Haas, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 0.9 (20041103)

The (made up) sender address =?iso-8859-1?Q?X=F6fren=2C_Yzzzzz?=
<xyz@example.com> is not properly displayed in the mail list and mail view.
Using reply creates two addresses "Xöfren" and "Yzzzzz <xyz@example.com>"
instead of one "Xöfren Yzzzzz <xyz@example.com>".

The sender displayed in the mail list is "Xöfren" instead of "Xöfren Yzzzzz".
Tha sender displayed in the mail view is "Yzzzzz <xyz@example.com>" instead of
"Xöfren Yzzzzz <xyz@example.com>".


Email for reproduction of the problem:

From - 
Subject: TOPIC
Date: Fri, 26 Nov 2004 11:26:11 +0100
Message-ID: <1234@example.com>
From: =?iso-8859-1?Q?X=F6fren=2C_Yzzzzz?= <xyz@example.com>
To: ME <me@example.com>

Hi

...

Regards



Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
Created attachment 167251 [details]
Email to reproduce the problem

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.