The URL http://offline_network_computer will do a search if that computer happens to be offline.

RESOLVED DUPLICATE of bug 263213

Status

()

Firefox
Address Bar
--
major
RESOLVED DUPLICATE of bug 263213
13 years ago
13 years ago

People

(Reporter: CoJaBo, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

When trying to connect to a computer on the network that is offline, a Google
search is performed. Firefox seems to be searching even if the URL contains
"HTTP://", which it should not do. (http://offline_network_computer)
I am reporting this as major since it is interfering enougf for me to have to
resort to IE to connect to network computers.

Reproducible: Always
Steps to Reproduce:
1. Go to URL http://offline_network_computer
Actual Results:  
Google search was run

Expected Results:  
Should have reported a timout trying to connect to http://offline_network_computer.

Running Firefox 1.0

Comment 1

13 years ago
WFM (I get an timeout) / Mozilla/5.0 (Windows; U; Windows NT 5.0; es-ES;
rv:1.7.5) Gecko/20041108 Firefox/1.0 without extensions.
(Reporter)

Comment 2

13 years ago
These are the test computers that do a search:
Firefox 1.0(not PR), Windows XP SP2, Extensions: DOM Inspector
Pentium III 500Mhz, 256MB RAM
Connected to router via Ethernet LAN

Firefox 1.0(not PR), Windows XP SP2, Extensions: Many
Athlon 64-bit 2.8 Ghz, 2GB RAM
Connected to router via Wireless LAN

The tested URLs:
http://main - a computer that exists, when it is running it connects to it, if
not running it searches for "main"
http://offline_network_computer - a computer that never existed, runs a search
for "offline_network_computer"
Summary: The URL http://offline_network_computer will do a search if the computer happens to be offline. → The URL http://offline_network_computer will do a search if that computer happens to be offline.

Comment 3

13 years ago
In Linux also it searches google (Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3)
Gecko/20040913 Firefox/0.10).

Comment 4

13 years ago
Dupe of bug 263213?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Dupe of bug 263213?
Yep, any idea when it will be fixed?

Comment 6

13 years ago
we aren't very good at predicting the future, you're welcome to buy some tea
leaves and give it a try. (alternatively, perhaps more productively, you could
try downloading the source, setting up a build environment, building, and then
working on the relevant portion of the mozilla codebase.)

*** This bug has been marked as a duplicate of 263213 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.