Open Bug 272125 Opened 17 years ago Updated 1 month ago

spam / Junk mail should not show in new message alert / play sound / notification

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: jarno.elovirta, Unassigned)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Whiteboard: [duptome] [see comment 40 for remaining problem])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: version 0.9 (20041103)

Thunderbird will always trigger the new message alert, even when all messages
have been detected to be junk. The new message alert preferences should allow
the user to set "No alert for junk mail".

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Summary: Junk mail should now trigger new message alert → Junk mail should not trigger new message alert
Should work for automatically detected messages, see Bug 189289. Does it work
before for you?
After more thorough testing (and waiting for spam), this feature seems unneccessary.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → WONTFIX
I don't understand why this bug has been set to wontfix.
It absolutley drives me nuts!!!!!
this was fixed in tb 1.5, wasn't it?
Duplicate of this bug: 386586
No, as you can see on bug 386586 this still happens for Thunderbird 2.

Shouldn't we pop-up the preview text after the junk filter moved the detected messages to the junk folder?
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
David, or should bug 386586 be handled separately because it points to the entries within the text preview? 
Assignee: mscott → nobody
Component: Preferences → Mail Window Front End
QA Contact: front-end
I can't even tell if this is IMAP or POP3 mail. However, for both of them, we've tried to make it so we only generate the new mail alert after the junk mail filtering has happened.
As example for my profile on that computer I use following junk handling: I have an IMAP account with different identities. Junk mail gets sort out and moved to the inbox of another IMAP account. That one I use as general junk account which will be processed by spamassassin on server side once a day.

If a new junk mail arrives for the first account and the message is moved to the second account I always get a new mail alert for the junk account. Sadly I'm not able to see what's inside the preview text due to there is no one on Mac OS X. :/

But anyway it is an example of the described issue which is not fully fixed at this time. David, hopefully this information gives you some ideas why it happens.
Status: UNCONFIRMED → NEW
Ever confirmed: true
so it's Thunderbird that's deciding that the message is junk, and the junk mail filter is moving the message to another imap account, and we still think there are new messages? I guess I can see why we'd think the message in the target account account is new...thx, Henrik, that's the kind of info that's helpful
I'm using Thunderbird 2.0.0.4 (20070604) on Windows XP SP 2 and the new email notification box regularly shows mails that are correctly detected as spam otherwise. This is for a POP3-Account, so it is a different setup than the one Henrik described in comment #9. I'm receiving all mails from different accounts into the optional unified Inbox. 

BTW: Bug 375545 is probably a duplicate of this bug.
Not really sure if it's different. I don't know anything about the backend stuff of the Global Inbox but also in this scenario messages are moved between different accounts. All messages which are received by each of the POP3 accounts have to be moved to the Global Inbox. I see a similarity in this action. 
So one cause of the problem could be that the new message notification is triggered when new mails are moved into the Inbox, whereas it should rather wait for the junk mail filters and show a notification only if not all mails were spam.

Unfortunately I don't have any experience with the Thunderbird Codebase, is there anything to do in order to help with this bug without delving into the code?
Duplicate of this bug: 375545
I'm getting this bug, and I'm not moving mail between accounts, I use the junk folder for each inbox.  POP mail as well.
I was just reminded of the biggest reason I wanted this fixed.  Because the new pop up shows the first bit of each mail, I'm getting some obscene things popping up now and then.  IMO this makes it a bug in the feature, not an enhancement.  Users shouldn't have to decide to turn off something quite useful (it's great for proper mail) to avoid things coming up on their screen at work or in front of kids that are inappropriate.
I do not see the popup for junk messages, but the new mail sound does play for junk messages. Is this a separate bug?
I use the MinimizeToTray extension and I get the mail icon in the system tray and new mail sound when new junk mail arrives. Is there a bug related to that extension?
(In reply to comment #17)
> new mail sound does play for junk messages. Is this a separate bug?

I'd think not.  Sound mentioned in older bug 233929.
Sound also a performance hit.

bug 365473 comment 5 also documents report of notification in 2.0 
Depends on: 233929
I see the visual and audio new message alert for junk messages (POP3 in use, not global inbox, in case that is relevant).  TB 2.0.0.9 / win32 (Vista Business).
I don't get a new message notification popup (nee biff) when junk mail arrives and gets filtered, but when some other message arrives the popup tends to list unread mails that are already marked as junk and reside in the Junk folder in my IMAP account.

Shouldn't biff skip listing unread mails that are in the Junk folder? After all, that's (amongst other things) what the Junk folder is for - or so I thought...
Duplicate of this bug: 454368
Duplicate of this bug: 365473
xref bug 460279 - Allow to ignore *non*-junk mail filtered into folders
Summary: Junk mail should not trigger new message alert → Junk mail should not show in nor trigger new message alert
Severity: normal, not enhancement, because it makes the new mail notification fairly unusable for me (more spam than ham).
Severity: enhancement → normal
Flags: wanted-thunderbird3?
Summary: Junk mail should not show in nor trigger new message alert → Junk mail should not show in new message alert
Compare bug 11040 - allow filters to set biffing.

I think this bug here is not a dup, because I think there should be a pref next to the Junk prefs which allows to ignore all Junk mail, without creating a custom filter, because I think almost all users will want that. I think the pref should be on by the default, too (which still would only have an effect if the Junk filter is enabled, of course).
Duplicate of this bug: 429050
Flags: blocking-thunderbird3?
I'm fed up receiving notifications for junk mails all the day long! This is a major bug guys. I can't imagine that it won't be solved in version 3! Ideally it should even be fixed in a v2.0 fix!!

No option, filter or choice should be added: nobody wants to be notified for junk-mail. No junk mail should trigger an alert, period.
Has anyone actually verified this is still a bug on the current 3.x builds?

Although the mac code may be slightly different, I've not noticed Junk Mail alerts when I've only received Junk mail. I think there's potential for the new mail alert to show incorrect details, but that's a different bug that is already filed.
Keywords: qawanted
the new mail code goes to a lot of trouble to avoid showing the new mail alert message for junk mail, and I have not seen it happen in a long time.
Well, I use TB3 (maybe a month old, just recompiled), and I saw this, enough to make the notifier useless, see comment 25. I'll try it out again.
Yes, still happens with trunk from yesterday.
(In reply to comment #32)
> Yes, still happens with trunk from yesterday.

Please clarify.

Do you get new mail alerts when you receive *just* junk mails?

or

Do you get new mail alerts when you receive both valid and junk mails *and* the new mail alerts contain information about the junk mails?
Mark: Both.

FYI, I'm on Linux, and use IMAP. I set up TB's junk mail feature to place spam in a spam folder. I just got a spam in my main inbox, recognized and filtered into spam folder, and I got *no* alert about it.

I think I know why I see this: I set up a separate IMAP account where I place all *server*-filtered spam. It's configured as account in TB, but I look at it only rarely. That account doesn't have TB's junk mail feature enabled. Unfortunately, I can't control the TB biff per account, only globally. I now disabled the periodic mail check on that account, and will watch what happens.
I just got another notification containing my last bugzilla comment and a spam (in the primary account, and recognized and filtered by TB as spam). So, Mark, at least your second option is true.
So you're getting told about server filter spam? If it's a single folder that gets the spam, you could mark it as the junk folder for that imap account, and then I think we would ignore it...
David, that's what comment 34 said, yes. I solved that.
In comment 35, I'm saying that I *also* get notifications on *client-side* filtered spam - at least when it's arriving together with ham.
Mark asked:
> Do you get new mail alerts when you receive both valid and junk mails
> *and* the new mail alerts contain information about the junk mails?

Yes, that seems to be the case. (Even on the primary account with client-side spam filtering.)

> Do you get new mail alerts when you receive *just* junk mails?

That does not seem to be the case.
> > Do you get new mail alerts when you receive *just* junk mails?

> That does not seem to be the case.

I just got a notification about 2 spams (no ham in the notification window).

I can see two possible reasons for that:
* A ham mail (the bugzilla notification about my last comment)
  arrived at the same time, but only 2 mails are displayed in the
  notification window, so the ham was not displayed, only the two spams,
  although the ham caused the notification.
* I had the spam folder selected at this moment. (I.e. in the main window,
  the client-side junk filtering folder was currently open and displayed.)
  It could be that the currently selected folder (Inbox for many people)
  causes all mail incl. junk to be biffed.
Without further information, the first option seems more likely, and it's in line with my last comment.
I *think* what happens is that if I have a new ham mail ("new" not meaning "unread", but "not seen", i.e. its folder hasn't been opened since it arrived, and/or I haven't touched TB at all since then), then all spam arriving after than is biffed. Even if the mail has already been shown long ago, and the biff is only about spam, no ham in the notification nor in the last time, the spam still is biffed.
Duplicate of this bug: 368345
Would be great to fix, but not blocking.
Flags: wanted-thunderbird3?
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Duplicate of this bug: 478812
I see this bug especially for Subfolders of my spam folder. Do you guys want a new bug filed on this, or is it possibly the same core issue?
Duplicate of this bug: 436082
(In reply to comment #6)
> No, as you can see on bug 386586 this still happens for Thunderbird 2.

AFAIR, problem of comment #0 of Tb 0.x to Tb 1.0.x was fixed by Tb 1.5, as David says in Comment #4. I think POP3 problem on Tb 2 which has same symptom as comment #0 is phenomenon I reported to Bug 496254.
Henrik Skupin, what do you think?
Bug summary of this bug, "Junk mail should not show in new message alert", is applicable to any Tb version, any cause of problem, if same external symptom.
Ben Bucksch(who closed many bugs for Tb 2 to this bug), should we DUP all bugs like Bug 496254(for Tb 2 or later only) to this bug which was initially opened for Tb 0.9?
I believe the best way to handle this is to leave open bugs for each reason that this problem occurs, and then mark those bugs as blocking this one.
(In reply to comment #47)
> I believe the best way to handle this is to leave open bugs for each reason
> that this problem occurs, and then mark those bugs as blocking this one.

To Majken "Lucy" Connor:

Do you mean "change this bug to meta bug for tracking"?
How about bugs for Tb 2 or later which were already closed as DUP of this bug?

How can we find "each reason" of each bug for Tb 2 or later do you think? (including bugs already closed as DUP of this bug)
I don't know better observation of problem than Comment #26 thru Comment #39 by Ben Bucksch, which is base of my guess/assumption in Bug 496254. (almost all bug reports say "new mail alert lies" only). So I checked one of simplest test cases(test case of Bug 496254), and opened Bug 496254 separately with my guess/assumption.
I think the cases of Junk mail staying in Inbox and Junk mail being filtered to the Junk folder, or other folder via filter, is different. Therefore, I think we should leave this bug open.
OS: Windows 2000 → All
Hardware: x86 → All
Whiteboard: see comment 40 for remaining problem
(In reply to comment #49)
> I think the cases of Junk mail staying in Inbox and Junk mail being filtered to
> the Junk folder, or other folder via filter, is different. Therefore, I think
> we should leave this bug open.

"Staying in Inbox/Junk filter" is Bug 324777(move spam to Junk) or Bug 362247(move spam to Trash), isn't it?
(Silent failure of "move by message filter" is similar but different issue. AFAIR, there are some bugs for it)
Please disregard my last comment.

> "Staying in Inbox/Junk filter" is Bug 324777 or Bug 362247

No. A user may choose to leave Junk in Inbox (deactivate the prefs to move to Junk or Trash folder), or Junk may be catched by a user filter to move to a normal folder.
(In reply to comment #51)
> No. A user may choose (A) to leave Junk in Inbox (deactivate the prefs to move to
> Junk or Trash folder), or (B) Junk may be catched by a user filter to move to a
> normal folder.
> (A or B is added by me)

As for B(mail marked as Junk/Non-Junk and moved to a normal or Junk folder by message filter), AFAIK, Tb doesn't apply Junk filter, at least after Tb 2.0. So I think (B) doesn't have relation to phenomenon of "new mail alert lies about new mail count".
Is it wrong?
Blocks: junktracker
Duplicate of this bug: 579893
Duplicate of this bug: 603698
Blocks: 534029
Whiteboard: see comment 40 for remaining problem → [duptome] [see comment 40 for remaining problem]
Duplicate of this bug: 659741
Can any of you TB engineers give an update on this very annoying bug? It's almost seven years since it was initially reported, and it still is not fixed. For example, just a few moments ago I received two new emails, both correctly identified by Thunderbird as junk and (per my preferences) moved to the junk folder. But a notification for both messages popped up. Earlier today, three new messages came, one valid, two junk. Of the junk, one slipped the filter and landed in my inbox, the other correctly moved to the junk folder. Thunderbird posted notifications for all three messages.

I am on Mac OSX. I'd very much appreciate an update, and even more, a fix.
We don't have anyone working on it specifically, but there's someone who will be taking a look at merging the three notification systems in the near future, and it's likely that this will end up being fixed in the work he does.

Thanks,
Blake.
Duplicate of this bug: 672517
This is still a problem in Thunderbird 14.0.

My conditions are:

- Inbox subdirectory labelled 'spam' will accumulate spam, but not trigger new message toast pop-up. This spam directory is handled by the mailserver, not Thunderbird. All spam in here are marked as *new*, this is typical behaviour of exim with Spamassassin
- If the main *Inbox* receives a new email, the toast pop-up notification appears, but instead previews the latest contents of the spam directory instead of the Inbox itself.

Given that my spam directories are cleverly named "spam", my expected results would be that Thunderbird, being the magnificent mail client that it is, would recognise that it is a directory dedicated to housing spam and thus should not be listed in the new mail toast pop-up.

Can somebody from UX clarify the current situation on this bug?
Summary: Junk mail should not show in new message alert → Junk mail should not show in new message alert, nor play sound if all new mails are junk
Duplicate of this bug: 823552
tentative bmo quicksearch for related bugs or dupes:

:thun,mail su:junk,spam su:sound,notification,biff,alert

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=%3Athun%2Cmail%20su%3Ajunk%2Cspam%20su%3Asound%2Cnotification%2Cbiff%2Calert;list_id=5281331
Summary: Junk mail should not show in new message alert, nor play sound if all new mails are junk → Junk mail should not show in new message alert / play sound
Can we have a feature where you can configure folder subscriptions to not display email alerts and/or otherwise behave as a folder dedicated for spam?

A lot of spam filtering happens server side and not everybody relies on Thunderbird's junk mail identifying mechanism.

Also, what do we need to do to get a dev to actually look at this issue?
Getting a look is easy, getting a patch is harder.

> Can we have a feature where you can configure folder subscriptions to not display email alerts

That makes sense. That was suggested several times above already. Can you file a bug for that, please?

Having TB new mail notification ignore Junk mail and ignore certain folders are different features. by default, Thunderbird has no Junk folder configured, so Junk mail ends up in INBOX (but marked as Junk), so we would need an explicit ignore of Junk mails, too.

Please note comment 38. This seems to be half-implemented.
> Can we have a feature where you can configure folder subscriptions to not display email alerts

I filed bug 988504 for ignoring certain folders.

Thus, this bug is now only about ignoring individual messages marked Junk, including those in INBOX.
Duplicate of this bug: 804125
Duplicate of this bug: 384437
Depends on: 343777
Keywords: qawanted
See Also: → 988504

I receive notifications for emails marked as spam in Thunderbird 60.9.0 (32-bit). It bugs me.

Duplicate of this bug: 1703800
Summary: Junk mail should not show in new message alert / play sound → spam / Junk mail should not show in new message alert / play sound / notification
You need to log in before you can comment on or make changes to this bug.