backups.number_of_prefs_copies ignored

RESOLVED DUPLICATE of bug 253259

Status

()

RESOLVED DUPLICATE of bug 253259
14 years ago
12 years ago

People

(Reporter: Bugzilla-alanjstrBugs, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The pref backups.number_of_prefs_copies used to work, and was good for
versioning prefs.js in case you broke something.  Now it doesn't work, but it
still appears in all.js.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
This appears to be either invalid or a dup of bug 246722 or bug 253259. 
According to those bugs, this pref is now intentionally obsoleted and disabled.
(Reporter)

Comment 2

14 years ago
Good catch, except those are for Seamonkey.  This is for Firefox.  Ok, so this
is obsoleted.  What replaced it?
the prefs backend is shared, so it doesn't matter which is which.  There isn't a
pref to dictate this any more, the need to have an arbitrary number of backups
was dealt with by using the "safe" write to disk function.

*** This bug has been marked as a duplicate of 246722 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

14 years ago
This still appears in all.js
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

14 years ago
I assume that the shared all.js on Trunk is 
http://lxr.mozilla.org/seamonkey/source/modules/libpref/src/init/all.js

*** This bug has been marked as a duplicate of 253259 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.