FireFox install does not create KDE/Gnome toolbar/desktop/start menu icons

RESOLVED INVALID

Status

()

Firefox
Installer
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: andrew, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: 

I am reporting this after reading a computer columnist's Nov 2004 column in a
local business paper titled "Linux OS still not quite ready for prime time yet".
He's a Mac & Windows user... he reported installing Mandrake Linux successfully,
then downloading and installing Firefox, which ran the first time OK, but he was
then umable to find a start icon. It might seem ludicrous to apparently rate an
entire operating system on something this trivial, but I guess it's a valid
point, similar to the "where did my download go?" issue that lead to the
download manager

Reproducible: Always
Steps to Reproduce:
1. Download FireFox on Mandrake Linux 
2. Install FireFox
3.

Actual Results:  
No obvious start icon for FireFox

Expected Results:  
Figured out if user was running KDE or Gnome, or maybe some other desktop
Added a start icon to the start menu, if possible.
Prompted user to add a start icon to toolbar
Prompted user to add a shortcut icon to desktop



When I installed FireFox (or Mozilla) myself on RedHat 9, I do not recall being
prompted for a desktop or toolbar icon. I don't use the start menu, so I can't
be certain that there was no FireFox icon (RedHat includes Mozilla), but I don't
think so.

Although Gnome and KDE might be prone to disparate user configurations,I would
think it possible to script some install procedure that would work in a majority
of cases.

Comment 1

13 years ago
You hit a deeper question here. Should Linux distros be some kind of second 
Windows/Apple. Or should users learn a new way of working (consoles). I would 
say the later. (Personally I don't really care for the market share of Linux, 
as long as I can use it.)

I would find it as experienced Linux user extremely annoying if a desktop icon 
would have been made. I don't use the desktop.

And there is the problem of how to detect where to store start icons (like you 
pointed out) because of the great variaty of window managers and distros.
Ultimately, the best form of distribution across Linux desktops is
distro-specific RPMs.  There just isn't enough consistency right now to make a
generic installer really workable, but that's just my opinion.

Updated

13 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → installer
marking this as invalid since the installer is no longer included in Firefox Release Builds for Linux. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.