When freetype2 newer than 2.1.7 is installed mozilla hangs-up or closes itself. ;)

RESOLVED DUPLICATE of bug 180309

Status

--
critical
RESOLVED DUPLICATE of bug 180309
14 years ago
14 years ago

People

(Reporter: masza02, Unassigned)

Tracking

({crash})

1.7 Branch
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040805 Netscape/7.2
Build Identifier: mozilla 1.7.2 and mozilla 1.7.3 and Firefox 1.0 

Mozilla and Firefox close. 

Bug: 

"run-mozilla.sh: line 159: 11272 Segmentation fault "$prog" ${1+"$@""

Reproducible: Always
Steps to Reproduce:
1.You must Compile and Install freetype2 >2.1.7 ( 2.1.9 or higher)
2.Startx
3.Open page "www.ati.com"
(Reporter)

Updated

14 years ago
Version: unspecified → 1.7 Branch
(Reporter)

Comment 1

14 years ago
Mozilla and Firefox close. 

Bug: 

"run-mozilla.sh: line 159: 11272 Segmentation fault "$prog" ${1+"$@""

Reproducible: Always
Steps to Reproduce:
1.You must Compile and Install freetype2 >2.1.7 ( 2.1.9 or higher)
2.Startx
3.Open page "www.ati.com"
(Reporter)

Comment 2

14 years ago
1.You must Compile and Install freetype2 >2.1.7 ( 2.1.9 or higher)

and enable BYTE CODE INTERPRETER (BCI)

Comment 3

14 years ago
Works fine for me. Reporter please provide a stacktrace. Bug is useless without it.
(Reporter)

Comment 4

14 years ago
hmmm: 
This GDB was configured as "i486-slackware-linux"..."/usr/bin/mozilla": not in 
executableformat: File format not recognized 
 
I can't compile mozilla fromn sources: 
 
nsFreeType.cpp:285: error: `FTC_Image_Cache' was not declared in this scope 
 nsFreeType.cpp:285: error: parse error before `,' token 
 nsFreeType.cpp: In member function `virtual nsresult 
    nsFreeType2::ImageCacheLookup(...)': 
 nsFreeType.cpp:289: error: `cache' undeclared (first use this function) 
 nsFreeType.cpp:289: error: (Each undeclared identifier is reported only once 
    for each function it appears in.) 
 nsFreeType.cpp:289: error: `desc' undeclared (first use this function) 
 nsFreeType.cpp:289: error: `glyphID' undeclared (first use this function) 
 nsFreeType.cpp:289: error: `glyph' undeclared (first use this function) 
 nsFreeType.cpp: At global scope: 
 nsFreeType.cpp:323: error: type specifier omitted for parameter ` 
    FTC_Image_Cache' 
 nsFreeType.cpp:323: error: parse error before `*' token 
 nsFreeType.cpp: In member function `virtual nsresult 
    nsFreeType2::ImageCacheNew(...)': 
 nsFreeType.cpp:326: error: `manager' undeclared (first use this function) 
 nsFreeType.cpp: At global scope: 
 nsFreeType.cpp:392: error: `FTC_Image_Cache' was not declared in this scope 
 nsFreeType.cpp:392: error: `aCache' was not declared in this scope 
 nsFreeType.cpp:393: error: `nsresult nsFreeType2::GetImageCache' is not a 
    static member of `class nsFreeType2' 
 nsFreeType.cpp:393: error: syntax error before `{' token 
 nsFreeType.cpp: In member function `void nsFreeType2::ClearGlobals()': 
 nsFreeType.cpp:429: error: `mImageCache' undeclared (first use this function) 
 gmake[4]: *** [nsFreeType.o] B??d 1 
 gmake[4]: Leaving directory `/root/mozilla/gfx/src/freetype' 
 gmake[3]: *** [libs] B??d 2 
 gmake[3]: Leaving directory `/root/mozilla/gfx/src' 
 gmake[2]: *** [libs] B??d 2 
 gmake[2]: Leaving directory `/root/mozilla/gfx' 
 gmake[1]: *** [tier_9] B??d 2 
 gmake[1]: Leaving directory `/root/mozilla' 
 make: *** [default] B??d 2 

Comment 5

14 years ago
> This GDB was configured as "i486-slackware-linux"..."/usr/bin/mozilla": not in 
> executableformat: File format not recognized 

try
% mozilla -g -d gdb
(but I'm 

> nsFreeType.cpp:285: error: `FTC_Image_Cache' was not declared in this scope 

that's bug 234035
Keywords: crash
(Reporter)

Comment 6

14 years ago
I'm opening page www.ati.com, mozilla crash.

gdb trace:

Starting program: /usr/lib/mozilla-1.7.3/mozilla-bin
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 4292)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbolsfound)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...[New Thread 32769 (LWP 4293)]
[New Thread 16386 (LWP 4294)]
*** Registering -webcal handler.
*** Registering text/calendar handler.
*** Registering webcal protocol handler.
Detaching after fork from child process 4295.
[New Thread 32771 (LWP 4297)]
[New Thread 49156 (LWP 4298)]
[New Thread 65541 (LWP 4299)]
[New Thread 81926 (LWP 4300)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 4292)]
0x40f9bdfc in nsTextFrame::TextStyle::TextStyle ()
   from /usr/lib/mozilla-1.7.3/components/libgklayout.so

Comment 7

14 years ago
0x40f9bdfc in nsTextFrame::TextStyle::TextStyle ()
   from /usr/lib/mozilla-1.7.3/components/libgklayout.so

that's bug 180309 (.fon font) or one of its companions (unreadable font, corrupt
font config)

Comment 8

14 years ago
the other person who experienced this bug gave me a few talkback ids
(tb2747425k, tb2747476W, tb2747499y) and they have stack trace similar to bug
180309.

Also see bug 180309 comment 65, which says nsTextFrame::TextStyle::TextStyle is
the same bug probably. bug 180309 is said to be fixed in 1.7.5.

Reporter, please try Mozilla 1.7.5 and reopen this if it doesn't work for you
(but see bug 180309 comment 100+ first)

*** This bug has been marked as a duplicate of 180309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.