mouse wheel and arrow keys don't scroll elements which have a scrollbar due to "overflow: auto" css

VERIFIED DUPLICATE of bug 97283

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 97283
14 years ago
14 years ago

People

(Reporter: Thomas Parslow, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

The mouse wheel and arrow keys can not be used to scroll elements which have
been made scrollable using "overflow: auto" CSS. The only way I to scroll them
is to use the click on the scrollbar. This is different from the way IFrames are
handled  even though they can look exactly the same to the user.
I've also reproduced this bug in Mozilla on Windows 2000 and Firefox on Linux
(Gentoo using the latest ebuild) and Windows XP.

Reproducible: Always
Steps to Reproduce:
1. Create a page with a div element, give it a style attribute of "overflow:
auto; height: 100px" and give it enough text to make it scroll (the text of this
bug report it probably sufficient).
2. Open it up in Firefox. Scroll bars should show at the right edge of the div
element.
3. Position mouse over the text and scroll the mouse wheel.

Actual Results:  
Nothing happens.

Expected Results:  
The content in the div area should scroll.
(Reporter)

Comment 1

14 years ago
Created attachment 167332 [details]
HTML document which demonstrates the problem.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 97283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.