Labels for Form input controls not aligning properly if there is text in the left menu bar

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: William Cays, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041122

In the page http://www.wolper.com/mozillatest.htm, the labels are not aligning
to the left of the input controls as long as there is text in the left menu bar.
If there is no text in the left menu the form in the content area is properly
layed out as shown in this page: http://www.wolper.com/mozillatest_good.htm. The
error first showed up in Firefox 1.0. The page displays fine in Mozilla 1.7,
preview releases of Firefox, and IE but not in the latest nightly build of
Mozilla (1.8a5) or in FireFox 1.0. The page is layed out using CSS containers. I
have validated the html using the W3C markup validation service and the CSS
using the W3C CSS Validator.

Reproducible: Always
Steps to Reproduce:
1.Open the page at http://www.wolper.com/mozillatest.htm
2.
3.

Actual Results:  
The form in the main container is not layed out properly

Expected Results:  
Labels should be aligned to the left of each input control
I think the fix for bug 148994 is responsible for this change. Before that fix
Mozilla did it wrong.

Comment 2

14 years ago
Yeah, Martijn's right. The behaviour used to be incorrect, and now it's correct. 

It looks like you can fix the site by just removing the clear, though :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.