Closed Bug 272308 Opened 17 years ago Closed 12 years ago

Weight form completion data by frequency used

Categories

(Toolkit :: Form Manager, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 370117

People

(Reporter: netdragon, Unassigned)

Details

A weighting could be used on saved form data to weight the alphabetical listing
of the forms and change their order slightly based on how often you use them..
For instance:

say you have used the following in forms:
aaaaaaa
abcdefg
app
apple
apparent

Normally, they'd be arranged as follows:
aaaaaaa
abcdefg
app
apparent
apple

But let's say that you have used the form entries the following number of times:
aaaaaaa -- 1 time
abcdefg -- 2 times
app -- 5 times
apparent -- 4 times
apple -- 20 times

Then when you type a, they should be arranged like:
apple
app
apparent
abcdefg
aaaaaaa

When you type ap, they should be arranged like:
apple
app
apparent

on and on. That way, the order is based first off alphabetically, and within the
remaining results, on how often you use that particular one.
Assignee: dveditz → nobody
Product: Core → Toolkit
QA Contact: form.manager
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370117
You need to log in before you can comment on or make changes to this bug.