Firefox 1.0 XPI langpacks on ftp.mozilla.org are located counter-intuitively and confusingly

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
14 years ago
5 years ago

People

(Reporter: ville.pohjanheimo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.7.5) Gecko/20041119 Firefox/1.0 (Debian package 1.0-3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.7.5) Gecko/20041119 Firefox/1.0 (Debian package 1.0-3)

At the moment the language packs for Firefox 1.0 can be found from two locations:
pub/mozilla.org/firefox/releases/1.0/linux-i686/xpi and
pub/mozilla.org/firefox/releases/1.0/win32/xpi

The above xpi directory is at the same level as language codes for the localized
builds. Naturally a user usually looks up his own language code and does not
wander to the end the directory listing and thus gets lost.

The issue is further confused by the fact, that XPI's are by design,
cross-platform files and should not reside under a certain platfom. Also, in
case the user in question is using a platform other than Win32 or Linux, he is
totally lost as there is no place for him to check for the XPI for his platform
(unless he's aware of the present directory structure and that xpi's are
cross-platform). 

My proposed solution is to create a new directory at the 'platform-level' i.e.:
pub/mozilla.org/firefox/releases/1.0/languagepacks

and store the language packs for each language there. Intuitively and obviously.

At the least the platform/ab-CD/ directory should include a direct link to the
corresponding language pack. (But this won't solve the problem for non-win32,
non-linux users)

The old solution of referring users to MLP's listing of localized Mozilla
products (and xpi's) is not usable for Firefox 1.0 as the page has not been
updated since 1.0 PR (and it seems it never will be updated for that release).

Reproducible: Always
Steps to Reproduce:
--> Build & Release
Assignee: mitchell → build
Component: Miscellaneous → Build & Release
QA Contact: mitchell → preed

Comment 2

13 years ago
1.0.x is pretty old (and now EOLed).

Because of that, we shouldn't futz with the location of bits that have been around for so long.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Assignee: build → nobody
QA Contact: mozpreed → build
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.