Last Comment Bug 272429 - Backport FF/TB extension mechanism [Extension Manager (EM)] to Seamonkey
: Backport FF/TB extension mechanism [Extension Manager (EM)] to Seamonkey
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- enhancement with 7 votes (vote)
: seamonkey2.0a1
Assigned To: general
:
Mentors:
: 315073 326292 (view as bug list)
Depends on: 255807 suiterunner
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 08:31 PST by Eyal Rozenberg
Modified: 2010-04-21 02:39 PDT (History)
28 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
add Extension/Theme Manager entries to Tasks menu (5.87 KB, patch)
2006-04-21 12:09 PDT, Robert Kaiser (not working on stability any more)
no flags Details | Diff | Review
Better patch (3.64 KB, patch)
2006-04-21 14:14 PDT, neil@parkwaycc.co.uk
kairo: review+
jag-mozilla: superreview+
Details | Diff | Review

Description Eyal Rozenberg 2004-11-30 08:31:02 PST
Why are we not seeing the firefox/thunderbird extension mechanism in seamonkey?
I talking both about the front end (GUI for installing, uninstalling, enabling,
disabling and configuring extensions) plus the backend (perhaps store extensions
like ff/tb? Perhaps not? Even in the latter case there already exists an
extension uninstaller for seamonkey which seems to work, here:
http://jgillick.nettripper.com/extuninstaller
).

And it seems about time to retire the install.js in favor of the ff/tb-like
install.rdf
Comment 1 WADA 2005-07-29 22:31:34 PDT
After enhanced extension manager implementation, minor design change has been made.
See "Enhanced Extension Installation" (
http://www.mozilla.org/projects/firefox/extensions/em-changes.html ) and Bug
297312 for minor changes (exentensions-startup is renamed to extensions.cache.)
Comment 2 Stephen Donner [:stephend] - PTO; back on 5/28 2005-11-04 21:36:51 PST
*** Bug 315073 has been marked as a duplicate of this bug. ***
Comment 3 Robert Kaiser (not working on stability any more) 2006-04-21 12:09:17 PDT
Created attachment 219341 [details] [diff] [review]
add Extension/Theme Manager entries to Tasks menu

Once SeaMonkey is running as a MOZ_XUL_APP, it's easy to get the extension manager working. This patch, originally by Mark Banner ("Standard8"), adds EM and Theme Manager to the Tasks menu in the case when we are building as such a "new toolkit" application.
Comment 4 Robert Kaiser (not working on stability any more) 2006-04-21 12:10:44 PDT
add Mark to CC, as he's the original author of this patch
Comment 5 Eyal Rozenberg 2006-04-21 13:09:21 PDT
Uh, this patch only adds the GUI... which should probably wait until the backend is ready. Or am I misunderstanding?
Comment 6 Mark Banner (:standard8) 2006-04-21 14:10:16 PDT
(In reply to comment #4)
> add Mark to CC, as he's the original author of this patch
> 
Thanks.

(In reply to comment #5)
> Uh, this patch only adds the GUI... which should probably wait until the
> backend is ready. Or am I misunderstanding?
> 
The backend is ready for "suiterunner" builds - they are ones where MOZ_XUL_APP=1 is defined which is what the ifdefs in this patch check for. Whilst we're not ready to flip the switch yet for trunk builds, we're in a good enough state for suiterunner builds to add this - they already have the new chrome registry/startup/profiles in place.
Comment 7 neil@parkwaycc.co.uk 2006-04-21 14:14:28 PDT
Created attachment 219364 [details] [diff] [review]
Better patch
Comment 8 neil@parkwaycc.co.uk 2006-04-21 14:15:54 PDT
Doh! I just realized I added emOverlay.xul in the wrong place :-(
Comment 9 Robert Kaiser (not working on stability any more) 2006-04-21 14:51:37 PDT
Comment on attachment 219364 [details] [diff] [review]
Better patch

basically looks good to me, but could you please add the new file as suite/common/emOverlay.xul instead and reference it from suite/common/jar.mn (including the overlay line), so that we don't create a new file in xpfe/ just before moving all the suite-specific files out there?

Actually, we might look into removing that additonal overlay at some later stage and merge it back into tasksOverlay, as we probably have too many overlays already. But that's something we can take care of once we've completely switched to suiterunner.
Comment 10 neil@parkwaycc.co.uk 2006-04-23 04:34:24 PDT
Fix checked in to the trunk for suiterunner builds only (WONTFIX for xpfe).
Comment 11 zug_treno 2008-01-31 08:57:21 PST
*** Bug 326292 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.