Firefox isn't properly rendering any site.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: misterholloway, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

I'm new to Firefox, and have just installed it.  Every website I try
is being rendered in this god-awful blue blackground with white text. 
It's not like a web page at all.

At first I thought it was maybe not rendering the CSS correctly, but
now it seems to me that it's just not doing much to even render the
HTML.  I mean, even for a site with no style sheet, just straight
HTML, this white-on-blue is being used.

Is Firefox using its own CSS?  If so, how do I turn that off?  Or
rather, what is the solution to my problem?

Reproducible: Always
Steps to Reproduce:
1.  Open Firefox.
2.  Go to any site.
3.  Enjoy blue background and white text no matter what.

Actual Results:  
I get to see the page rendered with white text on a blue background.  Graphics
do come through, although not placed as the CSS would have them.

Expected Results:  
Should have shown the page just as Mozilla and Opera and IE do.

I'm not doing anything special, nor accessing any special sites, nor running any
kind of special equipment.  WinXP Home on a standard Dell box.  I can send you a
JPG showing side-by-side Mozilla and Firefox looking at the mozilla home page
and you can see that Mozilla is rendering as expected while Firefox is showing
everything in this white-on-blue fashion that is making my eyeballs bleed.

TIA
(Reporter)

Comment 1

14 years ago
Created attachment 167437 [details]
shows moz and ff side by side on same site

shows what the problem is
*** Bug 272431 has been marked as a duplicate of this bug. ***
*** Bug 272432 has been marked as a duplicate of this bug. ***
It seems to me like you either installed FF incorrectly or somehow one of FF's
css files got messed up. Did you try reinstalling the browser and creating a new
profile? You can find instructions on creating a new profile at:

http://www.mozilla.org/support/firefox/profile

It might also be a video driver issue, although I would doubt that this is the
case here.

I've never seen anything like this before, maybe someone here has and will know
what it's about.
(Reporter)

Comment 5

14 years ago
Thank you, Gavin, that was indeed my problem.  Somehow the user profile was not
created when I installed FF.  Once I used the Profile Manager to generate one
for me, the Firefox browser started working just fine.

Is there any chance that this is due to my having converted over from Opera? 
During the FF install there is a step that asks if I want to import my Opera
stuff (bookmarks and the like).  I did choose to do that, and now I wonder what
would have happened if I had not.

I  _can_  say that I did try uninstalling and re-installing repeatedly, but I
suspect the FF uninstall is not "complete".  I say that because it was only the
 _first_  time that I was asked about importing the Opera stuff.

Again, thank you, Gavin, for your fast help.  I look forward to working with FF :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
If nothing actually changed in Firefox as a result of this bug, we mark it
WORKSFORME, not FIXED.

If you could try reproducing the problem again, it would be valuable to see if
maybe it is an issue with Opera profile migration. If you can reproduce it
consistently, then it would be worth filing a bug. No worries if it's too much
of a hassle though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.