If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash when I attempt to open a page at http://danzcontrib.free.fr [@ nsStyleContext::GetStyleData]

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Dan, Assigned: dbaron)

Tracking

({crash, regression})

Trunk
x86
Windows 2000
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8a4+) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041122

Mozilla crashes each time I attempt to open a page of the site.
No such problem with Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8a4)
Gecko/20040927
I also use Multizilla 1.7.0.0h, with both versions.
No problem with Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.7.5)
Gecko/20041107 Firefox/1.0
 

Reproducible: Always
Steps to Reproduce:
1.type the site address
2.
3.
Actual Results:  
Mozilla crashes or freezes. Downloads are stopped and the mail cannot be opened,
the quality agent tries to send a report but cannot access the server.

Comment 1

13 years ago
Confirming, Talkback TB2280271M
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20041130

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB2280271M
Stack Signature	 nsStyleContext::GetStyleData cd0c4d5b

I had 3 crashes, 
first crashed immediately with yesterdays nightly,
second crashed with new nightly only after Shift-Reloading, and then I deleted
compreg.dat to get Talkback working, and third crash was when loading the page,
and genrated this talkback.
Whiteboard: Talkback

Comment 2

13 years ago
Incident ID: 2280271 
Stack Signature nsStyleContext::GetStyleData cd0c4d5b 
Product ID MozillaTrunk 
Build ID 2004113004 
Trigger Time 2004-11-30 17:35:34.0 
Platform Win32 
Operating System Windows 98 4.10 build 67766222 
Module GKLAYOUT.DLL + (000b1797) 
URL visited http://danzcontrib.free.fr/activiterobots.php 
User Comments Bug 272467 crash when I attempt to open a page at 
http://danzcontrib.free.fr 
Since Last Crash 153 sec 
Total Uptime 153 sec 
Trigger Reason Access violation 
Source File, Line No. 
c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsSt
yleContext.cpp, line 248 
Stack Trace  

nsStyleContext::GetStyleData  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/content/base/src/nsS
tyleContext.cpp, line 248]
IsPercentageAwareChild  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 1108]
nsBlockFrame::ReflowInlineFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 4119]
nsBlockFrame::DoReflowInlineFrames  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3852]
nsBlockFrame::ReflowInlineFrames  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3698]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2697]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsBlockReflowContext::ReflowBlock  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockReflowContext.cpp, line 547]
nsBlockFrame::ReflowBlockFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3430]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2605]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsFrame::BoxReflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsFrame.cpp, line 5351]
nsFrame::RefreshSizeCache  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsFrame.cpp, line 4848]
nsFrame::GetPrefSize  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsFrame.cpp, line 4947]
nsScrollBoxFrame::GetPrefSize  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsScrollBoxFrame.cpp, line 461]
nsHTMLScrollFrame::GetPrefSize  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 931]
nsBoxFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBoxFrame.cpp, line 811]
nsHTMLScrollFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 508]
nsBlockReflowContext::ReflowBlock  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockReflowContext.cpp, line 547]
nsBlockFrame::ReflowBlockFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3430]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2605]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsBlockReflowContext::ReflowBlock  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockReflowContext.cpp, line 547]
nsBlockFrame::ReflowBlockFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3430]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2605]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsBlockReflowContext::ReflowBlock  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockReflowContext.cpp, line 547]
nsBlockFrame::ReflowBlockFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3430]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2605]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsBlockReflowContext::ReflowBlock  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockReflowContext.cpp, line 547]
nsBlockFrame::ReflowBlockFrame  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 3430]
nsBlockFrame::ReflowLine  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2605]
nsBlockFrame::ReflowDirtyLines  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 2234]
nsBlockFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsBlockFrame.cpp, line 835]
nsContainerFrame::ReflowChild  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsContainerFrame.cpp, line 972]
CanvasFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsHTMLFrame.cpp, line 550]
nsFrame::BoxReflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsFrame.cpp, line 5351]
nsFrame::DoLayout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsFrame.cpp, line 5091]
nsIFrame::Layout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBox.cpp, line 805]
nsScrollBoxFrame::DoLayout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsScrollBoxFrame.cpp, line 329]
nsIFrame::Layout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBox.cpp, line 805]
nsBoxFrame::LayoutChildAt  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBoxFrame.cpp, line 2687]
nsGfxScrollFrameInner::LayoutBox  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 1667]
nsGfxScrollFrameInner::Layout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 1809]
nsHTMLScrollFrame::DoLayout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 1083]
nsIFrame::Layout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBox.cpp, line 805]
nsBoxFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/
nsBoxFrame.cpp, line 853]
nsHTMLScrollFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 508]
nsContainerFrame::ReflowChild  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsContainerFrame.cpp, line 972]
ViewportFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsViewportFrame.cpp, line 249]
IncrementalReflow::Dispatch  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsPresShell.cpp, line 908]
PresShell::ProcessReflowCommands  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsPresShell.cpp, line 6254]
ReflowEvent::HandleEvent  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsPresShell.cpp, line 6083]
PL_HandleEvent  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/pleven
t.c, line 693]
PL_ProcessPendingEvents  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/pleven
t.c, line 631]
nsEventQueueImpl::ProcessPendingEvents  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsEven
tQueue.cpp, line 402]
0x16007004

@see bug 244665
Assignee: general → dbaron
Component: General → Style System (CSS)
Keywords: crash
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Summary: crash when I attempt to open a page at http://danzcontrib.free.fr → crash when I attempt to open a page at http://danzcontrib.free.fr [@ nsStyleContext::GetStyleData]
Whiteboard: Talkback
Version: unspecified → Trunk

Comment 3

13 years ago
Regression:
Tinderbox BuildID 2004112600 working,
BuildID 2004112806 crashing, zip build missing talkback files. 
Keywords: regression

Comment 4

13 years ago
working:  BuildID 2004112606
crashing: BuildID 2004112707

Checkins:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=20041126+04%3A00&maxdate=20041127+08%3A00&cvsroot=%2Fcvsroot

Perhaps regression from
Bug 271869. mBorderWidths need not be per-nsStyleBorder/nsStyleOutline, put it
in the prescontext instead. 


CSS-Errors seen in JS-console:
Error: Unknown property 'b¬kground-color'.  Declaration dropped.
Source File: http://danzcontrib.free.fr/css/not_msie.css
Line: 6

.demi div:hover{
b\ackground-color:#F2FAFF;/*hide from konqueror*/
}

Error: Error in parsing value for property 'top'.  Declaration dropped.
Source File: http://danzcontrib.free.fr/css/mozillag.css
Line: 575

top:expression(body.scrollTop + 30 + "px");/*ie5 5.5*/

Error: Expected ',' or '{' but found '";"'.  Ruleset ignored due to bad selector.
Source File: http://danzcontrib.free.fr/css/mozillag.css
Line: 582

voice-family:inherit;
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

13 years ago
TB2294031W Stack Signature	 nsStyleContext::GetStyleData 8f46322a

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB2294031W

First Talkback made on Win98, this one made on another computer running Win98SE
Couldn´t crash with a local copy, crashed only when loaded from URL in another
tab, or shift-reloaded, maybe reloaded.

Both Talkback differ only in 2 linenumbers, having same functionnames:

from TB2280271M
nsHTMLScrollFrame::Reflow  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 508]
nsHTMLScrollFrame::DoLayout  
[c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/html/base/src
/nsGfxScrollFrame.cpp, line 1083]


 508                        if (aDesiredSize.mComputeMEW)
is in function
 492 bryner         3.162 nsHTMLScrollFrame::Reflow(nsPresContext* 


1083 bryner         3.156   nsBox::DoLayout(aState); 
is in function
1077                      nsXULScrollFrame::DoLayout(nsBoxLayoutState& aState)


corresponds to TB2294031W

1031 dbaron         3.114   if (aDesiredSize.mComputeMEW)
is in function
1015 bryner         3.162 nsXULScrollFrame::Reflow(nsPresContext*    





 580 bryner         3.156   nsBox::DoLayout(aState);
is in function
 574                      nsHTMLScrollFrame::DoLayout(nsBoxLayoutState& aState)
Maybe this is something similar as bug 268119. One of the stylesheets
(http://danzcontrib.free.fr/css/style_old_nn4.css) has some :first-letter rules.
But this is more or less a guess, because I have not been able to make a
reproducable testcase.
So, bug 268119 is fixed, and I've loaded the url testcase many times, but I
can't get it to crash anymore, using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a6) Gecko/20041215
Firefox/1.0+
Can anybody still crash this with a build with the fix for bug 268119?
No response; marking worksforme, since it does with a current build.  Please
reopen if this is reproducible in a trunk nightly or the upcoming 1.8a6.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 9

13 years ago
(In reply to comment #7)

> Can anybody still crash this with a build with the fix for bug 268119?

I crash using the last build before bug 268119 was fixed, BuildId 2004121205.
Don´t crash Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a6) Gecko/20050107
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsStyleContext::GetStyleData]
You need to log in before you can comment on or make changes to this bug.