If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

css does not render if doctype is XHTML 1.1

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
13 years ago
12 years ago

People

(Reporter: Benjamin Reed, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/168 (KHTML, like Gecko) Safari/168
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

This page, for some reason, does not render the css at all.  It is valid XHTML 1.1 and the CSS validates as 
well, so in theory the HTML is correct.

If I remove the doctype line from the page, it renders correctly.

Reproducible: Always
Steps to Reproduce:
1. go to the web site

Actual Results:  
page renders with no style

Expected Results:  
page renders with style (tables with various blue hues)

Comment 1

13 years ago
Error: The stylesheet http://wow.befunk.com/maypole.css was not loaded because
its MIME type, "text/html", is not "text/css".
Source File: http://wow.befunk.com/session/list
Line: 0

The site needs it server settings for css files corrected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

13 years ago
Status: RESOLVED → VERIFIED
--> Websites :: www.mozilla.com so timeless can close out Firefox :: Product Site.
Component: Product Site → www.mozilla.com
Product: Firefox → Websites
-> Firefox::General (939393)
Component: www.mozilla.com → General
Product: Websites → Firefox
You need to log in before you can comment on or make changes to this bug.