Closed Bug 272500 Opened 16 years ago Closed 16 years ago

History doesn't differentiate between capitalized and uncapitalized URLs

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 99091

People

(Reporter: mikebuch, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Some sites differentiate between foo.com/bar and foo.com/BaR .  If foo.com/bar
links to foo.com/BaR , then going from one to the other will not create a new
entry in the history (or at least, it does not work correctly with the Back button).

Reproducible: Always
Steps to Reproduce:
1.  Visit http://en.wikipedia.org/wiki/TeX .
2.  Find the place in the second paragraph where there is a link to "LaTeX", and
open that link in a new browser window.
3.  In the new window, click on the link near the top of the article to "latex".

(note that the URLs provided herein are examples - others surely exist).
Actual Results:  
The Back button remained disabled at the "latex" page.

Expected Results:  
The Back button should have become enabled, and clicking it should lead from the
"latex" page to the "LaTeX" page.

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.